POJ 2942 Knights of the Round Table(边双连通+染色法,好题)

Knights of the Round Table

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 14987 Accepted: 5022

Description

Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a small group of the knights isthere, while the rest are busy doing heroic deeds around the country. 

Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:

  • The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.
  • An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of votes, and the argument goes on.)

Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons). If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled. 
 

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ). 

The input is terminated by a block with n = m = 0 . 
 

Output

For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled. 
 

Sample Input

5 5
1 4
1 5
2 5
3 4
4 5
0 0

Sample Output

2

题意:

n(n<=1e3)个人,m(m<=1e6)对憎恨关系(双向),国王每次开会都会找奇数个人围成一圈坐在圆桌周围,求最少去掉多少人,使剩下的人都能有机会参加会议(1个人不算)。也就是说,剩下的每个人都至少在一个奇环里。

思路:我刚开始读错题了,结果一直WA,其实就是去掉所有不在奇环当中的人。

我们用憎恨关系的补图建图,用tarjan求一下边双连通分量,显然一个人若在某一个奇环当中,那么它所在的双连通分量的人都至少存在于一个奇环当中(双连通分量性质)。如果不存在于奇环中,那么这个联通分量的人都不会存在于奇环中。

于是把人不在奇环中的人都标记出来,最后一一减去即可。

判断奇环,显然可以用经典的染色法。

一定要认真读题。

代码:

#include<iostream>
#include<cmath>
#include<iomanip>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<string>
#include<queue>
#include<vector>
#include<map>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1005;
const int maxt=2000010;
int n,m,k;
int cnt,top,jishu,cnt_bri;
int dfs_pos[maxn],low[maxn],head[maxn],fa[maxn],sta[maxn],tmp[maxn];
bool ok[maxn],vis[maxn],insta[maxn];
int color[maxn],cc;
int eg[maxn][maxn];
struct node
{
    int v;
    int nex;
}e[200010];
void init()
{
    cnt=0;jishu=0;top=0;cnt_bri=0;
    memset(dfs_pos,0,sizeof(dfs_pos));
    memset(ok,0,sizeof(ok));
    memset(vis,0,sizeof(vis));
    memset(low,0,sizeof(low));
    memset(insta,0,sizeof(insta));
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    e[cnt].v=v;
    e[cnt].nex=head[u];
    head[u]=cnt++;
}
int jud(int u,int col)
{
    color[u]=col;
    for(int i=head[u];i!=-1;i=e[i].nex)
    {
        int v=e[i].v;
        if(!ok[v]) continue;
        if(color[v]!=-1)
        {
            if(color[v]==col) return 0;
            continue;
        }
        if(!jud(v,!col)) return 0;
    }
    return 1;
}
void dfs(int u,int pre)
{
    int v;
    low[u] = dfs_pos[u] = ++jishu;
    sta[top++] = u;//不断将拜访过的点压入栈
    insta[u]=1;
    for(int i = head[u];~i;i = e[i].nex)
    {
        v = e[i].v;
        if(v==pre) continue;
        if(!dfs_pos[v])
        {
            dfs(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>=dfs_pos[u])
            {
                cnt_bri++;
                int vn;
                cc=0;
                memset(ok,0,sizeof(ok));
                do
                {
                    vn=sta[--top];
                    fa[vn]=cnt_bri;
                    insta[u]=0;
                    ok[vn]=1;
                    tmp[cc++]=vn;
                }while(v!=vn);
                ok[u]=1;
                memset(color,-1,sizeof(color));
                if(!jud(u,0))
                {
                    vis[u]=1;
                    while(cc--)
                    vis[tmp[cc]]=1;
                }
            }
        }
        else low[u] = min(low[u],dfs_pos[v]);
    }
}

int main()
{
    int i,j,k;
    int T,cas=1;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        init();
        for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {
            eg[i][j]=eg[j][i]=1;
        }
        for(i=0;i<m;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            eg[x][y]=eg[y][x]=0;
        }
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        if(eg[i][j]) add(i,j);

        for(int i=1;i<=n;i++)
        if(!dfs_pos[i]) dfs(i,-1);

        int ans=n;
        if(n<3) printf("%d\n",n);
        else
        {
            for(int i=1;i<=n;i++)
            if(vis[i]) ans--;
            printf("%d\n",ans);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值