WOJ1047-LCS Problem

Recently, Flymouse reads a book about Algorithm and Data Structure. The book reads: there are two types of LCS Problems. One is

Longest Common Subsequence problem. By the way of Dynamic Programming, we could solve this problem. The other is
Longest Common Substring problem, which is to find the longest string that is substrings of the two strings.
For example, given the following two strings:
1. flymouseEnglishpoor
2. comeonflymouseinenglish
The longest common substring is flymouse, the length of this string is 8.

输入格式

The first line contains a single integer t (1 <= t <= 100), the number of test cases.There will be two lines for each test case, each line

contains a string (The length of the two strings are no more than 2000 and you can assure all strings will not contains any punctuation
or other separators).

输出格式

For each test case, you should output one line containing the longest common substring?s length of the two strings of the test case.

样例输入

1
flymouseEnglishpoor
comeonflymouseinenglish

样例输出

8

最长公共子串问题,暴力解决

#include<stdio.h>
#include<string.h>
char s1[2016],s2[2016];
int len1,len2;
int main(){
	int t,i,j,k,ans;
	scanf("%d",&t);
	while(t--){
		ans=0;
		scanf("%s %s",&s1,&s2);
		len1=strlen(s1);len2=strlen(s2);
		for(i=0;i<len1;i++){
			if(len1-i<=ans)
			break;
			for(j=0;j<len2;j++){
				if(s1[i]==s2[j]){
					k=1;
					while(s1[i+k]!='\0'&&s2[j+k]!='\0'&&s1[i+k]==s2[j+k])
					k++;
					if(ans<k)
					ans=k;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值