LightOJ 1275:Internet Service Providers

13 篇文章 0 订阅
10 篇文章 0 订阅

Description

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

求解一元二次方程    我们知道 -ax^2+bx+c 最大值是在x=  -b/(2a)处取得

<pre name="code" class="cpp">#include<cstdio>
int main()
{
	long long t,cut=0;
	scanf("%lld",&t);
	while(t--)
	{
		cut++;
		long long n,c;
		scanf("%lld%lld",&n,&c);
		printf("Case %lld: ",cut);
		if(n==0)
		{
				printf("0\n");
		continue;
		}
	      long long a=(c/n)/2;//这里结果可能为小数 因为定义为int型结果就只取整数部分  那么结果就不一定是最大了 需要将x向左或右移一位 
		    long long b=a+1;
	  	printf("%lld\n",a*(c-a*n)>=b*(c-b*n)?a:b);
	}
	return 0;
 } 


 
  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值