HDU--3033 I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3693    Accepted Submission(s): 1514


Problem Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
                                                                       

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 
Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

Sample Input
5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66
 
Sample Output

255

思路:分组背包,每组最少取一个,按照组序号排序,然后进行分组背包,

当组序号发生改变时,进入下一组

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define mmax(a,b) a>b?a:b
int dp[12][10010];
struct goods
{
    int x,y,z;
}a[110];
int cmp(const void *a,const void *b)
{
    return (*(struct goods *)a).x-(*(struct goods *)b).x;
}
int main()
{
    int i,j,h,kk,n,m,k;
    while(scanf("%d %d %d",&n,&m,&k)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].z);
        memset(dp,-1,sizeof(dp));
        for(i=0;i<=m;i++)
            dp[0][i]=0;
        qsort(a,n,sizeof(a[0]),cmp);
        kk=0;
        int xx=-1;
        for(i=0;i<n;i++)
        {
            if(a[i].x!=xx)//不相同,进入下一组
            {
                kk++;
                xx=a[i].x;
            }
            for(h=m;h>=a[i].y;h--)
            {
                if(dp[kk][h-a[i].y]!=-1)//dp[kk][h-a[i].y]!=-1已经取了一个,在此基础上再取
                    dp[kk][h]=mmax(dp[kk][h],dp[kk][h-a[i].y]+a[i].z);
                if(dp[kk-1][h-a[i].y]!=-1)//dp[kk-1][h-a[i].y]!=-1至少取一个
                    dp[kk][h]=mmax(dp[kk][h],dp[kk-1][h-a[i].y]+a[i].z);
                //dp[kk][h-a[i].y]==-1&&dp[kk-1][h-a[i].y]==-1无满足条件取法,并将状态传递下去
            }
        }
        int ans=-1;
        for(i=0;i<=m;i++)//可能会有的组没有出现(kk<m),这种情况应输出Impossible
            if(dp[k][i]>ans)
            ans=dp[k][i];
        if(ans>=0)  printf("%d\n",ans);
        else  printf("Impossible\n");
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值