HDU--3449 Consumer

Consumer

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/65536K (Java/Other)

Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output

For each test case, output the maximum value FJ can get

Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60

Sample Output

201

思路一:依赖性背包,对每组物品先进行01背包,找出每组的所有策略,优化后进行分组背包,每组最多取一个
AC代码:
#include<stdio.h>
#include<string.h>
#define mmax(a,b) a>b?a:b
int main()
{
    int i,j,k,h;
    int m,n,s;
    int sum,box;
    int a[1005],b[1005],A[1005];
    int dp[110000];
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            sum=0;
            memset(A,0,sizeof(A));
            scanf("%d %d",&box,&s);
            for(j=0;j<s;j++)
            {
                scanf("%d %d",&a[j],&b[j]);
                sum+=a[j];
            }
            for(j=0;j<s;j++)//进行01背包,找出所有可能出现的策略
            {
                for(k=sum;k>=a[j];k--)
                    A[k]=mmax(A[k],A[k-a[j]]+b[j]);
            }
            h=0;
            a[h]=0;
            b[h++]=A[0];
            for(k=1;k<=sum;k++)//对此组的策略进行优化,去掉多余的策略(不优化会超时)
                if(A[k]!=A[k-1])
            {
                a[h]=k;
                b[h++]=A[k];
            }
            for(j=m;j>=0;j--)
            {
                for(k=0;k<h;k++)
                if(j>=a[k]+box)
                    dp[j]=mmax(dp[j],dp[j-a[k]-box]+b[k]);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}
思路二:先默认买箱子,然后对箱子对应的物品进行01背包,然后再决定买不买箱子及对应物品
AC代码:
 
 
#include<stdio.h>
#include<string.h>
#define mmax(a,b) a>b?a:b
#define Nbox 55
#define mone 100010
int dp[Nbox][mone];
int main()
{
    int i,j,n,w,pi,mi,c,v,l;
    while(scanf("%d %d",&n,&w)!=EOF)
    {
        memset(dp,-1,sizeof(dp));
        memset(dp[0],0,sizeof(dp[0]));
        for(i=1;i<=n;i++)
        {
            scanf("%d %d",&pi,&mi);
            for(j=pi;j<=w;j++)//买箱子
                dp[i][j]=dp[i-1][j-pi];
            for(j=1;j<=mi;j++)//箱子可装的东西进行01背包
            {
                scanf("%d %d",&c,&v);
                for(l=w;l>=c;l--)
                    if(dp[i][l-c]!=-1)
                        dp[i][l]=mmax(dp[i][l],dp[i][l-c]+v);
            }
            for(j=0;j<=w;j++)//是否买此箱子及对应的物品
                dp[i][j]=mmax(dp[i][j],dp[i-1][j]);
        }
        printf("%d\n",dp[n][w]);
    }
    return 0;
}
 
 
 
 
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值