NYOJ 179 LK's problem

32 篇文章 0 订阅
27 篇文章 0 订阅

LK's problem

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述
LK has a question.Coule you help her?
It is the beginning of the day at a bank, and a crowd  of clients is already waiting for the entrance door to  open. 
Once the bank opens, no more clients arrive, and  tellerCount tellers begin serving the clients. A  
teller takes serviceTime minutes to serve each client.  clientArrivals specifies how long each client has  already been waiting at the moment when the bank door  opens. Your program should determine the best way to arrange the clients into tellerCount queues, so that  the waiting time of the client who waits longest is minimized. The waiting time of a client is the sum of  the time the client waited outside before the bank opened, the time the client waited in a queue once the  bank opened until the service began, and the service time of the client. Return the minimum waiting time for the client who waits the longest.
输入
The input will consist of several test cases. For each test case, one integer N (1<= N <= 100) is given in the first line. Second line contains N integers telling us the time each client had waited.Third line contains tow integers , teller's count and service time per client need. The input is terminated by a single line with N = 0.
输出
For each test of the input, print the answer.
样例输入
2
1 2
1 10
1
10 
50 50
0

样例输出

21
60
题意 银行开门之前,一些人已经在门口等着办理业务。一个人等待的时间=开门前等待时间+开门后排队时间+办理业务所用时间。每个人办理业务所用时间相同,且看门后没有新增的人。问如何安排这些人的次序,能够使得等待时间最长的那个人等待的时间最短。求等待时间最长的那个人等待的时间的最小值。

       每组数据先输入一个N,代表有N个人,第二行有N个数,代表每个人在银行开门前的等待时间,第三行有二个数,分别代表银行服务人员的个数和每个人办理业务所用的时间(每个人所用时间相同).输出等待时间最长的那个人等待的时间的最小值。

         刚开始看完这个题,我的想法是这样的:先对每个人的等待时间排序,然后求出开门前等待时间最短的那个人所用的时间就行了。后来仔细想想不行,比如

5

1 2 3 4 5

2 1

这组数据,如果用那种方法做,最短时间为3,而实际上应该是6。

所以应该是先对开门前等待时间排序后,求出每一个人所用的时间(开门前等待时间长的先办理),然后再对每个人所用时间排序,输出最大的那个时间即可。感觉有点贪心算法的思想。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int n,a[102],i,t,c,min,s[102],j,p;
	while(~scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
	   sort(a,a+n);/*对开门前的等待时间排序*/
        scanf("%d%d",&c,&t);
        memset(s,0,sizeof(s));
		j=0,p=1;
		for(i=n-1;i>=0;i--)
		{
		    if(j==c)
			{
				p++;
				j=0;
			}
			j++;
			s[i]=a[i]+p*t; /*求出每个人所用的时间*/
		}
		sort(s,s+n); /*再次排序*/
		printf("%d\n",s[n-1]); /*输出最大值*/
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值