NYOJ 179 LK's problem

LK's problem

时间限制: 3000  ms  |  内存限制: 65535  KB
难度: 1
描述
LK has a question.Coule you help her?
It is the beginning of the day at a bank, and a crowd  of clients is already waiting for the entrance door to  open. 
Once the bank opens, no more clients arrive, and  tellerCount tellers begin serving the clients. A  
teller takes serviceTime minutes to serve each client.  clientArrivals specifies how long each client has  already been waiting at the moment when the bank door  opens. Your program should determine the best way to arrange the clients into tellerCount queues, so that  the waiting time of the client who waits longest is minimized. The waiting time of a client is the sum of  the time the client waited outside before the bank opened, the time the client waited in a queue once the  bank opened until the service began, and the service time of the client. Return the minimum waiting time for the client who waits the longest.
输入
The input will consist of several test cases. For each test case, one integer N (1<= N <= 100) is given in the first line. Second line contains N integers telling us the time each client had waited.Third line contains tow integers , teller's count and service time per client need. The input is terminated by a single line with N = 0.
输出
For each test of the input, print the answer.
样例输入
2
1 2
1 10
1
10 
50 50
0
样例输出
21
60

 

思路:略。

#include <stdio.h>
#include <stdlib.h>

int comp ( const void *a, const void *b )
{
    return * ( int * ) a - * ( int * ) b;
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF && n)
	{
		int i,c,t,a[110];
		int max = -1,j = 0,p = 1;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		qsort(a,n,sizeof(int),comp);
		scanf("%d%d",&c,&t);
		for(i=n-1;i>=0;i--)
		{
			if(j==c)
			{
				p++;
				j=0;
			}
			j++;
			if (max < a[i]+p*t)
			{
				max = a[i]+p*t;
			}
		}
		printf("%d\n",max); 
	}
	return 0;
}



 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值