LK's problem 05

LK's problem

时间限制:3000 ms  |  内存限制:65535 KB

难度:1

描述

LKhas a question.Coule you help her?

Itis the beginning of the day at a bank, and a crowd  of clients is alreadywaiting for the entrance door to  open. 

Oncethe bank opens, no more clients arrive, and  tellerCount tellers beginserving the clients. A  

tellertakes serviceTime minutes to serve each client.  clientArrivals specifieshow long each client has  already been waiting at the moment when the bankdoor  opens. Your program should determine the best way to arrangethe clients into tellerCount queues, so that  the waiting time of theclient who waits longest is minimized. The waiting time of a client is thesum of  the time the client waited outside before the bank opened,the time the client waited in a queue once the  bank opened until theservice began, and the service time of the client. Return the minimumwaiting time for the client who waits the longest.

输入

Theinput will consist of several test cases. For each test case, one integer N(1<= N <= 100) is given in the first line. Second line contains Nintegers telling us the time each client had waited.Third line contains towintegers , teller's count and service time per client need. The input isterminated by a single line with N = 0.

输出

Foreach test of the input, print the answer.

样例输入

2

1 2

1 10

1

10

50 50

0

样例输出

21

60


代码如下:

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main()
{
int n;//代表人数 
while(scanf("%d", &n), n != 0)
{
	int i,j,sum;
	int a[200], t;
	for(i = 1; i <= n; i ++)
	scanf("%d", &a[i]);//每个人在开门前等待的时间放在数组中 
	//-------------------选择排序--------------------- 
	for(i = 1; i < n; i++)//使用选择排序,注意起点改变了吗
	for(j = i + 1; j < n+1; j ++)
	if (a[i] < a[j])//由大到小排序了! 
	{
	t = a[i];
	a[i] = a[j];
	a[j] = t;
 }
 //------------------------现在是将每个人在开门前等待的时间排序了! 
	int tcount, servtim, num, m;//tcount是人数,servtim 是银行人员办理业务所用的时间 
	scanf("%d %d", &tcount, &servtim);
	num = n / tcount;//总分数除以银行人数 
	m = n % tcount;//如果是0 要等待,如果是非零就直接办理 
	if(m == 0)
	sum = a[(num-1)*tcount+1] + num * servtim;//这里需注意一下;
	else
	sum = a[1 + num * tcount] + (num + 1) * servtim;//这里也是;
	printf("%d\n", sum);
  }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值