HDU 5879 Cure

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 580    Accepted Submission(s): 206


Problem Description
Given an integer  n , we only want to know the sum of  1/k2  where  k  from  1  to  n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer  n
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
  
  
1 2 4 8 15
 

Sample Output
  
  
1.00000 1.25000 1.42361 1.52742 1.58044
 

Source

比赛的时候一直提示runtime error   原来输入是数组,诶,我这个小白被坑上面了。无奈。
代码附上啊:
#include <stdio.h>
#include <string.h>

double a[1000001]={0};
char b[1000005];
int main()
{
	int i,j,len,n;
	double sum,tmp;
	
	for(i=1;i<=1000000;i++)
	{
		tmp=i*1.0;
		a[i]=a[i-1]+(1.0)/(tmp*tmp);
	}
	while(~scanf("%s",b))
	{
		len=strlen(b);
		n=0;
		if(len>=7)
			printf("%.5lf\n",a[1000000]);
		else
		{
			for(j=0;j<len;j++)
			{
				n=n*10+b[j]-'0';
			}
			printf("%.5lf\n",a[n]);
		}
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值