hdu5879Cure(java解法)

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1133    Accepted Submission(s): 377


Problem Description
Given an integer  n , we only want to know the sum of  1/k2  where  k  from  1  to  n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer  n
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
  
  
1 2 4 8 15
 

Sample Output
  
  
1.00000 1.25000 1.42361 1.52742 1.58044
 

Source
 

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		double num[] = new double[200000];
		Scanner cin = new Scanner(System.in);
		java.text.DecimalFormat   df   =new   java.text.DecimalFormat("#.00000");  
		
		num[0] = 0;
		for(int i=1;i<200000;i++)
		{
			num[i] = num[i-1]+1.0/i/i;
		}
		String str;
		
		while(cin.hasNext())
		{
			str = cin.nextLine();
			if(str.length()<=6)
			{
				int n = 0;
				for(int i =0 ; i<str.length();i++)
				{
					n = n*10+(str.charAt(i)-'0');
				}
				if(n<=200000){
					System.out.println(df.format(num[n]));
				}
				else
					System.out.println("1.64493");
			}
			else
				System.out.println("1.64493");
			
		}
	}

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值