HDU 2709 Sumsets 递推

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2489    Accepted Submission(s): 1003


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6
 

Source
 

Recommend
teddy   |   We have carefully selected several similar problems for you:   2544  2716  2710  2717  2715 
 
a[n] 为和为  n  的种类数;
根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数  n-1  的种类数  a[n-1]  ,若  n  为偶数时分加数中有无  1  讨论,即关键是对  n  为偶数时进行讨论:
1. n 为奇数, a[n]=a[n-1]
2. n 为偶数:
(1)如果加数里含1,则一定至少有两个1,即对 n-2 的每一个加数式后面  +1+1 ,总类数为 a[n-2]
(2)如果加数里没有1,即对 n/2 的每一个加数式乘以2,总类数为 a[n/2]
所以总的种类数为: a[n]=a[n-2]+a[n/2] ;
#include <stdio.h>

long long a[1000001]={0,1,2};
int main()
{
	int i,t;
	
	for(i=3;i<1000001;i++)
    {
        if(i%2==0)
            a[i]=a[i-2]+a[i/2];
        else
            a[i]=a[i-1]; 
        
		a[i]%=1000000000;   
    }
	while(~scanf("%I64d",&t))
	{
		printf("%I64d\n",a[t]);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值