HDU 5542 The Battle of Chibi

The Battle of Chibi

Time Limit: 6000/4000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1759    Accepted Submission(s): 625


Problem Description
Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao.

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering.

Yu Zhou discussed with Gai Huang and worked out  N  information to be leaked, in happening order. Each of the information was estimated to has  ai  value in Cao Cao's opinion.

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact  M  information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the  N  information and just select  M  of them. Find out how many ways Gai Huang could do this.
 

Input
The first line of the input gives the number of test cases,  T(1100) T  test cases follow.

Each test case begins with two numbers  N(1N103)  and  M(1MN) , indicating the number of information and number of information Gai Huang will select. Then  N  numbers in a line, the  ith  number  ai(1ai109)  indicates the value in Cao Cao's opinion of the  ith  information in happening order.
 

Output
For each test case, output one line containing  Case #x: y, where  x  is the test case number (starting from 1) and  y  is the ways Gai Huang can select the information.

The result is too large, and you need to output the result mod by  1000000007(109+7) .
 

Sample Input
  
  
2 3 2 1 2 3 3 2 3 2 1
 

Sample Output
  
  
Case #1: 3 Case #2: 0
Hint
In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.
 

Source
 

Recommend
wange2014
 

一开始没想到啥好办法就用了for循环,果然超时了

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=1e3+5;
const int mod=1e9+7;
int t,cas=0;
int n,m;
int a[maxn];
int dp[maxn][maxn];

int main(){
	
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++){
			scanf("%d",a+i);
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			dp[i][1]=1;
		}
		for(int i=1;i<=n;i++){
			for(int j=1;j<=min(i,m);j++){
				for(int k=1;k<i;k++){
				 	if(a[k] <= a[i]){
						dp[i][j]=(dp[k][j-1]+dp[i][j])%mod;
					}
				}
			}
		}
		int ans=0;
		for(int i=1;i<=n;i++){
			ans=(ans+dp[i][m])%mod;
		}
		printf("Case #%d: ",++cas);
		printf("%d\n",ans);
	}	
	
	
	return 0;
}


在网上看了看,都是用树状数组进行优化,一会补上代码



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值