2015南阳理工CCPC The Battle of Chibi

The Battle of Chibi

Time Limit: 6000/4000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao.

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering.

Yu Zhou discussed with Gai Huang and worked out  N  information to be leaked, in happening order. Each of the information was estimated to has  ai  value in Cao Cao's opinion.

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact  M  information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the  N  information and just select  M  of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases,  T ( 1100 ).  T  test cases follow.

Each test case begins with two numbers  N ( 1N103 ) and  M ( 1MN ), indicating the number of information and number of information Gai Huang will select. Then  N  numbers in a line, the  ith  number  ai ( 1ai109 ) indicates the value in Cao Cao's opinion of the  ith  information in happening order.

Output

For each test case, output one line containing Case #x: y, where  x  is the test case number (starting from  1 ) and  y  is the ways Gai Huang can select the information.

The result is too large, and you need to output the result mod by  1000000007 ( 109+7 ).

Sample input and output

Sample Input Sample Output
2
3 2
1 2 3
3 2
3 2 1
Case #1: 3
Case #2: 0

Hint

In the first cases, Gai Huang need to leak  2  information out of  3 . He could leak any  2  information as all the information value are in increasing order. In the second cases, Gai Huang has no choice as selecting any  2  information is not in increasing order.

Source

The 2015 China Collegiate Programming Contest
题解:   dp[i][j]表示以第i个人为最后一个选取j个人的方案数, 最后结果, 从dp[1][m] + ... dp[n][m]即可.
           我们题解维护dp[i][j]的时候, 可以用树状数组来维护, 总体的时间复杂度N^2log(N).
   (通过次题我明白了, 取模是一个多么慢的东西! )



#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int N = 1010;
const int MOD = 1000000007;

int dp[N][N];

struct node{
	int x, id;
	bool operator<(const node & a) const{
		return x < a.x;
	}
}Node[N];

struct array{
	int ary[N][N];
	void init() { memset(ary, 0, sizeof(ary)); }
	int lowbit(int x) {
		return x & (-x);
	}
	void insert(int r, int c, int x) {
		while (c < N) {
			ary[r][c] += x;
			while (ary[r][c] >= MOD) ary[r][c] -= MOD;
			c += lowbit(c);
		}
	}
	int query(int r, int c) {
		int ans = 0;
		while (c) {
			ans += ary[r][c];
			while (ans >= MOD) ans -= MOD;
			c -= lowbit(c);
		}
		return ans;
	}

}tree;

int main() {
	int T;
	int cnt = 0;
	scanf("%d", &T);

	while (T--) {
		int n, m;
		scanf("%d%d", &n, &m);

		int ary[N];
		for (int i = 1; i <= n; ++i) {
			scanf("%d", &Node[i].x);
			Node[i].id = i;
		}

		Node[0].x = 0;
		sort(Node + 1, Node + n + 1);
		int C = 1;
		for (int i = 1; i <= n; ++i)
			if (Node[i].x == Node[i - 1].x)
				ary[Node[i].id] = C;
			else
				ary[Node[i].id] = ++C;

		tree.init();
		for (int i = 1; i <= n; ++i) {
			int x = i < m ? i : m;
			dp[i][1] = 1;
			for (int j = 2; j <= x; ++j) 
				dp[i][j] = tree.query(j - 1, ary[i] - 1);
			for (int j = 1; j <= i; ++j)
				tree.insert(j, ary[i], dp[i][j]);
		}

		int ans = 0;
		for (int i = m; i <= n; ++i) {
			ans += dp[i][m];
			while (ans >= MOD) ans -= MOD;
		}

		printf("Case #%d: %d\n", ++cnt, ans);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值