poj 2533 最长上升子序列 多种姿势

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 54789 Accepted: 24545

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion


最长上升子序列,简单dp,O(n*n)就可以过

O(n*n)代码:

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define ll long long
#define inf 1e18+5

using namespace std;
int a[1010],dp[1010],n;

int main(){
	
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		int mmax;
		for(int i=0;i<=n;i++)
			dp[i]=0;
		dp[1]=1;
		for(int i=2;i<=n;i++){
			mmax=0;
			for(int j=1;j<i;j++){
				if(a[j] < a[i] && mmax < dp[j])
					mmax=dp[j];
			}
			dp[i]=mmax+1;
		}
		mmax=0;
		for(int i=1;i<=n;i++){
			mmax=max(mmax,dp[i]);
		}
		printf("%d\n",mmax);
	}
	
	
	return 0;
}

n*log(n)代码:

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define ll long long
#define inf 1e18+5

using namespace std;
int a[1010],dp[1010],n;

int bin(int len,int k){
	int l=1,r=len;
	while(l <= r){
		int mid=(l+r)/2;
		if(k > dp[mid]){
			l=mid+1;
		}
		else
			r=mid-1;
	}
	
	return l;
}

int main(){
	
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		int mmax;
		for(int i=0;i<=n;i++)
			dp[i]=0;
		dp[1]=a[1];
		int ans=1,j; 
		for(int i=2;i<=n;i++){
			if(a[i] <= dp[1])
				j=1;
			else if(a[i] > dp[ans])
				j=++ans;
			else
				j=bin(ans,a[i]);
			
			dp[j]=a[i];
		}
		/*mmax=0;
		for(int i=1;i<=n;i++){
			mmax=max(mmax,dp[i]);
		}*/
		printf("%d\n",ans);
	}
	
	
	return 0;
}





以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值