HDU 1078 搜索+记忆化

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11163    Accepted Submission(s): 4735


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1080  1074  1024  1081  1025 
 

对这个题的题意纠结了好一会

在一个n阶方阵A中,Aij表示在第i行第j列的位置处所有的奶酪数目。老鼠起始位置为(0,0),老鼠在方阵中移动的规则是:<1>、每次最多沿着水平(或垂直)方向跳k格;
<2>、每次所跳至的格中奶酪数目要比当前位置处得多。求老鼠所能得到的奶酪的最大数目。

ac代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <cmath>
#include <algorithm>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int n,k;
int mmp[110][110];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int dp[110][110];

int dfs(int x,int y){
	
	if(dp[x][y])
		return dp[x][y];
	
	int ans=0;
	for(int i=0;i<4;i++){
		for(int j=1;j<=k;j++){
			int tmp_x=x+j*dir[i][0];
			int tmp_y=y+j*dir[i][1];
			if(tmp_x >=1 && tmp_x <=n && tmp_y >=1 && tmp_y <=n && mmp[x][y] < mmp[tmp_x][tmp_y]){
				int tmp=dfs(tmp_x,tmp_y);
				if( tmp > ans)
					ans=tmp;
			} 
		}
	}
	dp[x][y]=mmp[x][y]+ans;
	
	return dp[x][y];
}

int main(){
	
	while(scanf("%d%d",&n,&k)){
		if(n==-1 && k==-1)
			break ;
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				scanf("%d",&mmp[i][j]);
				dp[i][j]=0;
			}
		}
		dfs(1,1);
		printf("%d\n",dp[1][1]);
	}
	
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值