transaction transaction transaction
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)Total Submission(s): 1269 Accepted Submission(s): 609
Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
Input
The first line contains an integer
T
(
1≤T≤10
) , the number of test cases.
For each test case:
first line contains an integer n ( 2≤n≤100000 ) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x , y and z which means there exists a road between x and y , the distance is z km (1≤z≤1000) .
For each test case:
first line contains an integer n ( 2≤n≤100000 ) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x , y and z which means there exists a road between x and y , the distance is z km (1≤z≤1000) .
Output
For each test case, output a single number in a line: the maximum money he can get.
Sample Input
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
Sample Output
8
Source
Recommend
题意很简单,就是从这个城市进货,去另外一个城市卖,路费算进去书的成本
dp:
dp[nn[i].end]=max(dp[nn[i].end],dp[nn[i].star]-a[nn[i].star]-nn[i].road+a[nn[i].end]);
ac代码:
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
int t;
int n;
int a[100005];
int dp[100005];
struct node{
int star,end;
int road;
}nn[200005];
int main(){
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
}
int x,y,z;
int cnt=0;
for(int i=1;i<=n-1;i++){
scanf("%d%d%d",&x,&y,&z);
nn[cnt].star=x;
nn[cnt].end=y;
nn[cnt++].road=z;
nn[cnt].star=y;
nn[cnt].end=x;
nn[cnt++].road=z;
}
memset(dp,0,sizeof(dp));
int mmax=0;
for(int i=0;i<cnt;i++){
dp[nn[i].end]=max(dp[nn[i].end],dp[nn[i].star]-a[nn[i].star]-nn[i].road+a[nn[i].end]);
mmax=max(mmax,dp[nn[i].end]);
}
printf("%d\n",mmax);
}
return 0;
}