HDU-6201 transaction transaction transaction (源点+汇点)最短路

Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is aiai yuanyuan in ii tt city. Kelukin will take taxi, whose price is 11 yuanyuan per km and this fare cannot be ignored.
There are n−1n−1 roads connecting nn cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.

Input

The first line contains an integer TT (1≤T≤101≤T≤10 ) , the number of test cases.
For each test case:
first line contains an integer nn (2≤n≤1000002≤n≤100000 ) means the number of cities;
second line contains nn numbers, the ii thth number means the prices in ii thth city; (1≤Price≤10000)(1≤Price≤10000)
then follows n−1n−1 lines, each contains three numbers xx , yy and zz which means there exists a road between xx and yy , the distance is zz kmkm (1≤z≤1000)(1≤z≤1000) .

Output

For each test case, output a single number in a line: the maximum money he can get.

Sample Input

1  
4  
10 40 15 30  
1 2 30
1 3 2
3 4 10

Sample Output

8

还是最短路问题,但是城市本身有权值,可以设一个超级源点和一个超级汇点,权值分别为a和-a,计算源点到汇点最短路

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
#define maxn 100005
#define INF 0x3f3f3f3f
struct node
{
	int to,next,w;
}e[maxn*4];
int head[maxn],cnt,n;
int dis[maxn],sum[maxn];
void add(int a,int b,int w)
{
	e[cnt].to=b;
	e[cnt].w=w;
	e[cnt].next=head[a];
	head[a]=cnt++;
}
void spfa(int s)
{
	int vis[maxn];
	queue<int>q;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n+2;i++)
	{
		dis[i]=-INF;
	}
	dis[s]=0;
	vis[s]=1;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=e[i].next)
		{
			int v=e[i].to;
			if(dis[v]<dis[u]+e[i].w)
			{
				dis[v]=dis[u]+e[i].w;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main()
{
	cin.tie(0);
	ios::sync_with_stdio(false);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		cnt=0;
		memset(head,-1,sizeof(head));
		for(int i=1;i<=n;i++)
		{
			cin>>sum[i];
		}
		for(int i=1;i<=n;i++)
		{
			add(n+1,i,-sum[i]);
			add(i,n+2,sum[i]);
		}
		for(int i=1;i<n;i++)
		{
			int a,b,w;
			cin>>a>>b>>w;
			add(a,b,-w);
			add(b,a,-w);
		}
		spfa(n+1);
		cout<<dis[n+2]<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值