PAT甲级 1064 Complete Binary Search Tree (30分)

1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

     

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4
    

解题思路:先按层序遍历建一课空的完全二叉树,然后将输入序列从小到大排序,之后按中序遍历依次将已排好序的序列插入建好的空树中,最后层序遍历建好的树。

#include<iostream>
#include<queue>
#include<algorithm>
#define Null -1
using namespace std;
struct node{
	int val;
	struct node *left, *right;
	int flag = 0;
};
node *nodeTemp;
int nodeFlag = 0;
node *newNode(int v){
	node *root = new node();
	root->val = v;
	root->left = root->right = NULL;
	return root;
}
void findNode(node *root){
	if(root->left){
		findNode(root->left);
	}
	if(!nodeFlag){
		if((root->left == NULL && root->val == Null) || (root->left != NULL && root->val == Null)){
			nodeTemp = root;
			nodeFlag = 1;
			return;
		}
	}
	if(root->right){
		findNode(root->right);
	}
}
void insert(node *root, int v){
	nodeFlag = 0;
	findNode(root);
	nodeTemp->val = v;
}

node *makeTree(int n){
	node *root = newNode(Null);
	queue<node*> q;
	q.push(root);
	for(int i = 1; i < n; i++){
		node *temp;
		temp = q.front();
		temp->left = newNode(Null);
		q.pop();
		q.push(temp->left);
		i++;
		if(i >= n){
			break;
		}
		temp->right = newNode(Null);
		q.push(temp->right);
	}
	return root;
} 
void levelTravel(node *root){
	queue<node*> q;
	q.push(root);
	printf("%d", root->val);
	if(root->left){
			q.push(root->left);
	}
	if(root->right){
		q.push(root->right);
	}
	q.pop();
	while(!q.empty()){
		node *temp = q.front();
		printf(" %d", temp->val);
		if(temp->left){
			q.push(temp->left);
		}
		if(temp->right){
			q.push(temp->right);
		}
		q.pop();
	}
}
int main(){
	int n, val;
	int a[1005];
	scanf("%d", &n);
	//建树
	node *root = makeTree(n);
	//填入值
	for(int i = 0; i < n; i++){
		scanf("%d", &a[i]);
	}
	sort(a, a + n);
	for(int i = 0; i < n; i++){
		insert(root, a[i]);
	}
	//层序遍历输出 
	levelTravel(root);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值