PTA Maximum Subsequence Sum

01-复杂度2 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N1N2, ..., NK }. A continuous subsequence is defined to be { NiNi+1, ..., Nj } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
作者: 陈越
单位: 浙江大学
时间限制: 200ms
内存限制: 64MB
代码长度限制: 16KB

 
import java.util.Scanner;
public class Main{
  
  public static void main(String []args){
    Scanner sc = new Scanner(System.in);
    int k =sc.nextInt();
    int m[]=new int[k];
    int sum = 0;
    int tempMinIndex=0;
    int minIndex=0;
    int maxIndex=0;
    for(int i =0;i<k;i++){
      m[i] = sc.nextInt();
    }
    int thisMax=m[0];
    for(int j=0;j<k;j++){
      if(sum>=0){
        sum+=m[j]; 
      }
      else{
       sum=m[j];
       tempMinIndex=j;
      }
      if(sum>thisMax){
        thisMax = sum;
        maxIndex=j;
        minIndex=tempMinIndex;
      }
      if(thisMax<0){
        thisMax=0;
        minIndex=0;
        maxIndex=k-1;
      }
    }
    System.out.println(thisMax+" "+m[minIndex]+" "+m[maxIndex]);
  }
}


提交结果
提交时间状态分数题目编译器耗时用户
2018/4/4 21:17:03部分正确2201-复杂度2Java (openjdk)109 ms风的追忆


测试点提示结果耗时内存
0sample换1个数字。有正负,负数开头结尾,有并列最大和答案正确108 ms13228KB
1最大和序列中有负数答案正确105 ms16036KB
2并列和对应相同i但是不同j,即尾是0答案正确109 ms11472KB
31个正数答案正确103 ms14284KB
4全是负数答案正确106 ms14332KB
5负数和0答案错误108 ms13164KB
6最大和前面有一段是0答案正确106 ms13256KB
7最大N运行超时0 ms

0KB

啊啊啊啊啊啊,不知道为什么错了,有没有大佬帮忙看下啊,我还是先留个坑,之后有时间再来补补。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值