数据结构——学习问题——2004年浙江大学计算机专业考研复试真题

一、PAT考试题

Given a sequence of K integers { N​1, N2, ..., N​K}.
 A continuous subsequence is defined to be { Ni, Ni+1, ..., N​j} 

where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

第一次尝试代码:

// 输出最大值以及第一个和最后一个字符
	static HashMap<String, Integer> getSumAndElement(int[] a) {
		int tempSum = 0, MaxSum = 0;
		int length = a.length;
		Integer first = 0, last = 0;
		for (int i = 0; i < length; i++) {
			if (i == 0) {
				first = a[i];
			}
			tempSum = tempSum + a[i];
			if (tempSum > MaxSum) {
				MaxSum = tempSum;
				last = a[i];
				//这边还是需要一个判断变量的东西,不然会出现首位计算错误
			} else if (tempSum < 0) {
				tempSum = 0;
				if (i + 1 < length) {
					first = a[i + 1];
				} else {
					first = a[i];
				}
			}
		}
		HashMap<String, Integer> map = new HashMap<String, Integer>();
		map.put("maxSum", MaxSum);
		map.put("first", first);
		map.put("last", last);
		return map;
	}

然后全部错误=- =,测试点反正是没得分的,输出正确的就只有最大序列和和最后一位数。找了下原因是因为在获取第一个值的时候判定条件不够,于是找了网上的代码:

package arithmetic;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class UnivariatePolynoExanp {
	static int n;

	public static void main(String[] args) throws Exception {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));

		in.nextToken();
		int n = (int) in.nval;
		// 用于分段取得最大值,这样就不会出现第一个值出错的问题了。
		//上面那个,脑袋有毛病么,这就是个存放的数组,学傻了
		int[] num = new int[n];
		for (int i = 0; i < n; i++) {
			in.nextToken();
			num[i] = (int) in.nval;
		}

		int start = -1, end = 0, sum = -1;
		int s = -1, e = 0, temp = 0;
		int index = 0;
		while (index < n) {
			// 计算有正有负时
			if (num[index] >= 0) {
				temp = temp + num[index];
				e = index;
				//当这个是重头开始的时候,重新设置一个变量做切换就不会出现叠加到死的情况了,妈耶
				if (s == -1)
					s = index;
				if (temp > sum) {
					sum = temp;
					start = s;
					end = e;
				}
				// 单纯计算负数时
			} else {
				temp = temp + num[index];
				if (temp < 0) {
					temp = 0;
					//重置开头
					s = -1;
				} else {
					e = index;
				}
			}
			index++;
		}
		// 分开输出
		if (sum < 0 && n > 0) {
			//方式一致,为什么这是正确的?
			System.out.print("0" + " " + num[0] + " " + num[n - 1]);
		} else if (sum >= 0) {
			System.out.print(sum + " " + num[start] + " " + num[end]);
		} else {
			System.out.print(0);
		}
	}

}

这个代码就看着很让人嫉妒了,速度快且测试点全有,默默研究中。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值