hdu1160 FatMouse's Speed--DP&记录路径

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1160


一:原题内容

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 
Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 
Sample Output
  
  
4 4 5 9 7
 

二:分析理解

最长上升子序列。。

题目大意是找到一个最多的老鼠序列,使得序列中的老鼠的体重满足递增,相应老鼠的速度满足递减。思路就是先按体重递增进行sort排序,然后按照体重找到最长递减子序列即可,用动态规划做比较简单。状态f[i]表示前i个老鼠中的最长递减子序列长度,状态转移方程为f[i] = max{f[j], mice[j].speed > mice[i].speed} + 1, 最后找出最大的f[i]即可。注意此题还需要输出找到的序列中的老鼠的最原始的标号,因此不仅要在刚开始的时候把每个老鼠的最初的序号记下来,还要在进行状态转移的时候把当前的老鼠的位置标记下来。


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  

using namespace std;

struct Node
{
	int w;//weight
	int s;//speed
	int index;
}node[1500];

bool cmp(Node node1, Node node2)
{
	if (node1.w > node2.w) return 1;
	//if (node1.w == node2.w&&node1.s > node2.s) return 1;//这里写不写都可以

	return 0;
}

int dp[1500];
int pre[1500];
int res[1500];

int main()
{
	int n;
	int i = 1;
	int w, s;


	
	while (~scanf("%d%d", &w, &s))//需要连续按 ctrl+z+enter 3次才能结束输入,也是醉了!
	{
		dp[i] = 1;
		node[i].w = w;
		node[i].s = s;
		node[i].index = i;
		i++;
	}

	n = i - 1;//个数
	
	sort(node + 1, node + n + 1, cmp);

	int maxx = -1;//保存最大个数
	int maxx_end_index = 1;//对应最大个数的最后一个下标

	for (int j = 1; j <= n; j++)
	{
		for (int k = 1; k < j; k++)
		{
			if (node[k].w > node[j].w&&node[k].s < node[j].s&&dp[j] < dp[k] + 1)
			{
				dp[j] = dp[k] + 1;
				pre[j] = k;

				if (dp[j] > maxx)
				{
					maxx = dp[j];
					maxx_end_index = j;
				}
			}
		}
	}

	printf("%d\n", maxx);

	int t = maxx_end_index;

	while (t != 0)
	{
		printf("%d\n", node[t].index);
		t = pre[t];
	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值