Cleaning Shifts(贪心)

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

思路

这道题的思路用到了贪心的思想,当把n组数据输入完之后,先对它们进行从小到大的排序,对于开始工作时间相等的数据,对其结束工作的时间再次进行排序。然后从排序后的数据里面,从第一个数据进行比较,判断结束时间是否超过T,超过则输出sum,没超过则,继续搜索下一个数据,开始时间相同的数据则选择结束时间最久的那组数据。若是出现有时间段没有牛在工作的话,则输出-1

 

#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

int t,n;
struct node
{
    int s;
    int e;
}cow[25010];

bool cmp(node a,node b)
{
    if(a.s==b.s)
        return a.e<b.e;
    return a.s<b.s;
}

int main()
{
    while(scanf("%d %d",&n,&t)!=EOF)
    {
        int a,b;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&a,&b);
            cow[i].s=a;
            cow[i].e=b;
        }
        sort(cow,cow+n,cmp);
        /*for(int i=0;i<n;i++)
        {
            printf("%d %d\n",cow[i].s,cow[i].e);
        }*/
        int sum=0,l=0;
        int minn,maxx=0;
        while(maxx<t)
        {
            minn=maxx+1;
            for(int i=0;i<n;i++)
            {
                if(cow[i].s<=minn&&cow[i].e>=minn)
                {
                    //maxx=maxx>cow[i].e?maxx:cow[i].e;
                    maxx=max(maxx,cow[i].e);
                }
                else if(cow[i].s>minn)
                {
                    l=i;
                    break;
                }
            }
            if(minn>maxx)
                break;
            else
                sum++;
        }
        if(maxx>=t)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值