poj 2566 Bound Found

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

这题着实让我头疼了很久;
这题主要利用前缀和与尺取法;
首先算出前缀和,但是由于输入的数字是乱序的,就比较难处理,所以进行一次排序;
对排序好的使用尺取法,得到最终结果。
但即使是解决了算法问题,我仍是错了几次。
pair数组的大小问题,以及MIN的初值太小,都坑我了我几次。
我还是太native了。(多亏了大神的题解,让我发现了问题)
P.S 我第一次使用了pair,以前都是用struct自己创造的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
//数组的大小要控制好
pair<int,int> p[200000];
int main()
{
    int n,k,num;
    while(scanf("%d %d",&n,&k)&&n!=0&&k!=0)
    {
        int sum=0;
        p[0]=make_pair(0,0);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&num);
            sum+=num;
            //计算前缀和
            p[i]=make_pair(sum,i);
        }
        //排序
        sort(p,p+n+1);
        while(k--)
        {
            scanf("%d",&num);
            int MIN=1<<30;
            //尺取法
            int start=0,finish=1,ans_start,ans_end,ans_sum;
            while(start<=n&&finish<=n)
            {
                int temp=p[finish].first-p[start].first;
                if(abs(temp-num)<MIN)
                {
                    MIN=abs(temp-num);
                    ans_sum=temp;
                    ans_start=p[start].second;
                    ans_end=p[finish].second;
                }
                if(temp>num) ++start;
                else if(temp<num) ++finish;
                else if(temp==num) break;
                if(start==finish) ++finish;
            }
            //注意这里要交换一下,因为大小关系不确定
            if(ans_start>ans_end)
            {
                int t=ans_start;
                ans_start=ans_end;
                ans_end=t;
            }
            printf("%d %d %d\n",ans_sum,ans_start+1,ans_end);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值