POJ2566(77/600)

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

这个题是个很巧妙地尺取
因为是取了绝对值所以可以对前缀和进行排序
这样就是单调的了…
然后因为是前缀和所以差值还是能通过前缀和相减得到…
可以说是非常骚了

(poj还不倒闭嘛!!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
struct p
{
    ll  he,zb;
    bool operator < (const p&a)const
    {
        return he<a.he;
    }
};
p tu[100001];
ll  inf=0x3f3f3f3f3f3f3f3f;
int main()
{
    ll n,k;
    while(cin>>n>>k)
    {
        if(!n)break;
        memset(tu,0,sizeof(tu));
        for(ll a=1;a<=n;a++)scanf("%lld",&tu[a].he);
        for(ll a=1;a<=n;a++)tu[a].zb=a;
//      tu[0].he=-inf;
        for(ll a=1;a<=n;a++)tu[a].he=tu[a].he+=tu[a-1].he;
        sort(tu,tu+n+1);
        for(ll a=1;a<=k;a++)
        {
            ll q;
            scanf("%lld",&q);
            ll dz,dy,c=inf,ds;
            ll z=0,y=1;
            while(z<=n&&y<=n)
            {
                ll cha=tu[y].he-tu[z].he;
                if(fabs(cha-q)<c)
                {
                    c=fabs(cha-q);
                    dz=min(tu[y].zb,tu[z].zb);
                    dy=max(tu[y].zb,tu[z].zb);
                    ds=cha;
    //              cout<<c<<" "<<dz<<" "<<dy<<" "<<ds;
    //              cout<<endl;
                }
                if(cha<q)y++;
                else if(cha>q)z++;
                else break;
                if(z==y)y++;
            }
            printf("%lld %lld %lld\n",ds,dz+1,dy);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值