poj 2993 Emag eht htiw Em Pleh(关联2996)

Description

This problem is a reverse case of the  problem 2996. You are given the output of the problem H and your task is to find the corresponding input.

Input

according to output of  problem 2996.

Output

according to input of  problem 2996.

Sample Input

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

这题是一道模拟题,主要就是繁琐;

首先输出整张图,然后按照要求,改变特定位置的符号;


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    char map[36][34];
    //输出整张图
    for(int i=0;i<=16;i=i+2)
    {
        strcpy(map[i],"+---+---+---+---+---+---+---+---+");
    }
    for(int i=1;i<=13;i=i+4)
    {
        strcpy(map[i],"|...|:::|...|:::|...|:::|...|:::|");
    }
    for(int i=3;i<=15;i=i+4)
    {
        strcpy(map[i],"|:::|...|:::|...|:::|...|:::|...|");
    }
    string str1,str2;
    getline(cin,str1);
    getline(cin,str2);
    //更改White
    for(int i=7;str1[i]!='\0';++i)
    {
        if(str1[i]<='Z'&&str1[i]>='A')
        {
            //cout<<str1[i]<<endl;
            map[17-2*(str1[i+2]-'0')][4*(str1[i+1]-'a')+2]=str1[i];
            i=i+2;
        }
        else if(str1[i]<='h'&&str1[i]>='a')
        {
            //cout<<str1[i]<<endl;
            map[17-2*(str1[i+1]-'0')][4*(str1[i]-'a')+2]='P';
            ++i;
        }
    }
    //更改Black
    for(int i=7;str2[i]!='\0';++i)
    {
        if(str2[i]<='Z'&&str1[i]>='A')
        {
            //cout<<str1[i]<<endl;
            map[17-2*(str2[i+2]-'0')][4*(str2[i+1]-'a')+2]=str2[i]-'A'+'a';
            i=i+2;
        }
        else if(str2[i]<='h'&&str2[i]>='a')
        {
            //cout<<str1[i]<<endl;
            map[17-2*(str2[i+1]-'0')][4*(str2[i]-'a')+2]='p';
            ++i;
        }
    }
    for(int i=0;i<=16;++i)
        for(int j=0;j<=32;++j)
    {
        printf("%c",map[i][j]);
        if(j==32) printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值