poj 2082 Terrible Sets

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4188 Accepted: 2166

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source




这道的题意真的很难懂啊;
我也是参见了大神的题解才懂得;
大概就像是底边在一条直线上且相邻的长方形;
问连续长方形的最大面积;
最大面积要么是单独的一个长方形;
要么是它与之前的长方形联合组成;


#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<stack>
using namespace std;
struct S
{
    int w;
    int h;
}s[50005];
stack<S> st;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        int maxs=0;
        scanf("%d %d",&s[0].w,&s[0].h);
        st.push(s[0]);
        for(int i=1;i<n;++i)
        {
            scanf("%d %d",&s[i].w,&s[i].h);
            if(s[i].h>st.top().h)
            {
                st.push(s[i]);
            }
            else
            {
                int temp=0;
                while(!st.empty()&&s[i].h<=st.top().h)
                {
                    temp+=st.top().w;
                    maxs=max(maxs,temp*st.top().h);
                    st.pop();
                }
                S t;
                t.w=temp+=s[i].w;
                t.h=s[i].h;
                st.push(t);
            }
        }
        int temp=0;
        while(!st.empty())
        {
            temp+=st.top().w;
            maxs=max(maxs,temp*st.top().h);
            st.pop();
        }
        printf("%d\n",maxs);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值