Terrible Sets POJ - 2082

题目链接:点我


    Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
    Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
    Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
    Your mission now. What is Max(S)? 
    Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
    But for this one, believe me, it's difficult.

Input

    The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

题意:

不得不吐槽题意难以理解,题意的意思是给你n个矩形的长和宽,求他们所能组成的最大的矩形的面积.

思路:

单调栈,维护一个高度不断递增的单调栈,每次判断新元素的高是否大于最大的高,大于就直接进栈,否则不断从栈顶弹出元素,并且记录元素的总的宽,每次用当前的宽与弹出元素的高来更新ans,最后一定能得到最大的面积.

代码:

#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<iostream>
using namespace std;

const int maxn = 5e4+10;
int w[maxn],h[maxn];
int a[maxn];
int s[maxn];

int main(){
    int n;
    while(scanf("%d", &n) != EOF && n != -1){
        int ans = 0;
        int l = 1,r = 0;
        for(int  i = 1; i <= n;++i){
            scanf("%d %d", &w[i], &h[i]);
            if(h[i] < h[a[r]]){
            int sum = 0;
            while(l <= r && h[i] < h[a[r]]){//弹出栈顶元素
                sum += w[a[r]];
                ans = max(ans, h[a[r]] * sum);
                r--;
            }
            a[++r] = i;//新元素进栈
            w[i]+=sum;
            } else {
                a[++r] = i;
            }
        }
        int sum = 0;
        while(r){
                sum += w[a[r]];
                ans = max(ans,h[a[r]] * sum);
                r--;
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值