POJ 2082 Terrible Sets(可怕的矩形)

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4812 Accepted: 2465

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source


题意:

在 x 轴上给定一些不会重叠的矩形宽和高,求解出可以形成的最大矩形的面积。

思路:

我想的用的贪心,明显的会 GG。思路就是用一个按照高度 h 非递减的方式将已知矩形进栈,如果即将入栈的高度 data.h 比栈顶元素的高度 lasth 小。

就一直退到可以保持栈顶元素高度非递减的那个元素 x 位置,退栈过程中也不能闲着,统计由 lasth 到 x 之间可以形成的最大矩形的面积 S ,以及之间矩形的

总宽度 totalw,弹出以上所有元素之后再压入一个高度为 data.h,宽度为 towalw + data.w 的矩形就可以啦,继续键入下一个矩形......最后扫描一遍。

样例1 - >

参考来源:《ACM / ICPC 算法训练教程(余立功)》

AC CODE:

#include<cstdio>
#include<stack>
using namespace std;

struct rec {
	int w;
	int h;
} data;

int main()
{
	int n, ans, i, lasth, totalw, curarea;
	while(scanf("%d", &n) && n != -1) {
		ans = 0;
		stack<rec> s;
		lasth = 0;//上次进栈的矩形高度

		for(i = 0; i < n; i++) {
			scanf("%d%d", &data.w, &data.h);
			if(data.h >= lasth) {
				s.push(data);
			} else {//当前进栈的矩形高度较小
				totalw = 0;//总宽
				curarea = 0;//当前面积
				while(!s.empty() && s.top().h > data.h) {
					totalw += s.top().w;
					curarea = totalw * s.top().h;
					if(curarea > ans) ans = curarea;
					s.pop();
				}
				totalw += data.w;
				data.w = totalw;
				s.push(data);//新的矩形 
			}
			lasth = data.h;
		}
	
		totalw = 0;
		curarea = 0;//当前面积 
		while(!s.empty()) {
			totalw += s.top().w;
			curarea = totalw * s.top().h;
			if(curarea > ans) ans = curarea;
			s.pop();
		}

		printf("%d\n", ans);
	}
	return 0;
}

/*
4
1 3
2 3
3 3
4 3
30

4
3 4
3 3
3 2
3 1
18
*/


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值