Uva 657 The die is cast

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

InterGames is a high-tech startup company that specializes in developing technology that allows usersto play games over the Internet. A market analysis has alerted them to the fact that games of chanceare pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most ofthese games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter theresult into the computer, since cheating would be way to easy. So, instead, InterGames has decided tosupply their users with a camera that takes a picture of the thrown dice, analyzes the picture and thentransmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determinesthe numbers of dots on the dice.

We make the following assumptions about the input images. The imagescontain only three different pixel values: for the background, the diceand the dots on the dice. We consider two pixels connected if they sharean edge — meeting at a corner is not enough. In the figure, pixels A andB are connected, but B and C are not.

A set S of pixels is connected if for every pair (a, b) of pixels in S, thereis a sequence a1, a2, . . . , ak in S such that a = a1 and b = ak, and ai andai+1 are connected for 1 ≤ i < k.

We consider all maximally connected sets consisting solely of nonbackgroundpixels to be dice. ‘Maximally connected’ means that you cannotadd any other non-background pixels to the set without making it dis-connected. Likewise weconsider every maximal connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a linecontaining two numbers w and h, the width and height of the picture, respectively. These values satisfy5 ≤ w, h ≤ 50.

The following h lines contain w characters each. The characters can be: ‘.’ for a background pixel,‘*’ for a pixel of a die, and ‘X’ for a pixel of a die’s dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture willcontain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in thepicture, sorted in increasing order.

Print a blank line after each test case.

Sample Input

30 15

..............................

..............................

...............*..............

...*****......****............

...*X***.....**X***...........

...*****....***X**............

...***X*.....****.............

...*****.......*..............

..............................

........***........******.....

.......**X****.....*X**X*.....

......*******......******.....

.....****X**.......*X**X*.....

........***........******.....

..............................

0 0

Sample Output

Throw 1

1 2 2 4



开始以为*会把X包一圈,但好像并非如此;

搜索时,遇到X,要把周围的X打上标记,防止重复计点数;

代码写得比较丑;


#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#include<functional>
#define pi 3.14159265358979323846
using namespace std;
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
char maze[55][55];
bool vis[55][55];
bool flag[55][55];
int num[1250];
int w,h;
void dfs(int x,int y,int tol)
{
    if(!vis[x][y]&&maze[x][y]!='.')
        vis[x][y]=1;
    else return ;
    if(maze[x][y]=='X')
    {
        if(flag[x][y]==0)
        {
            num[tol]++;
            flag[x][y]=1;
        }
        for(int i=0;i<4;++i)
        {
            if(x+dx[i]<h&&x+dx[i]>=0&&y+dy[i]<w&&y+dy[i]>=0&&!vis[x+dx[i]][y+dy[i]]&&maze[x+dx[i]][y+dy[i]]=='X')
            {
                flag[x+dx[i]][y+dy[i]]=1;
            }
        }
        for(int i=0;i<4;++i)
        {
            if(x+dx[i]<h&&x+dx[i]>=0&&y+dy[i]<w&&y+dy[i]>=0&&!vis[x+dx[i]][y+dy[i]]&&maze[x+dx[i]][y+dy[i]]=='X')
            {
                dfs(x+dx[i],y+dy[i],tol);
            }
        }
    }

        for(int i=0;i<4;++i)
        {
            if(x+dx[i]<h&&x+dx[i]>=0&&y+dy[i]<w&&y+dy[i]>=0&&!vis[x+dx[i]][y+dy[i]])
            {
                dfs(x+dx[i],y+dy[i],tol);
            }
        }
    return ;
}
int main()
{
    int cnt=0;
    while(scanf("%d %d",&w,&h)!=EOF&&(w||h))
    {
        for(int i=0;i<h;++i)
        {
                scanf(" %s",&maze[i]);
        }
        memset(vis,0,sizeof(vis));
        memset(num,0,sizeof(num));
        memset(flag,0,sizeof(flag));
        int tol=0;
        printf("Throw %d\n",++cnt);
        for(int i=0;i<h;++i)
        {
            for(int j=0;j<w;++j)
            {
                if(!vis[i][j]&&maze[i][j]!='.')
                {
                    dfs(i,j,tol++);
                }
            }
        }
        sort(num,num+tol);
        for(int i=0;i<tol;++i)
        {
            if(i==0)
                printf("%d",num[i]);
            else printf(" %d",num[i]);
        }
        printf("\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值