hdu1083 Courses

9 篇文章 0 订阅
3 篇文章 0 订阅

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8464    Accepted Submission(s): 4124


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1068 2444 2063 1150 1281 




典型的模板题呀啊啊啊我伟大的匈牙利算法。
题意:有p门课程,n个学生,每个学生在一个committee代表一门课程,求学生和课程的最大匹配,若最大匹配等于p,输出YES,否则输出NO。
简简单单地建边呗,然后用上伟大的模板,具体匈牙利算法就不详讲了,或许以后会讲哒O(∩_∩)O~



#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int vis[10000],match[10000],map[1000][1000],p,n;
bool dfs(int k){
	int t;
	for(int i=1;i<=n;i++){
		if(!vis[i] && map[k][i]){
			vis[i]=true;
			t=match[i];
			match[i]=k;
			if(t==-1 || dfs(t)) return true;
			match[i]=t;
		}
	}
	return false;
}

int main()
{
	int T,num,k;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&p,&n);
		memset(map,0,sizeof(map));
		memset(match,-1,sizeof(match));
		for(int i=1;i<=p;i++){
			scanf("%d",&num);
			for(int j=1;j<=num;j++){
				scanf("%d",&k);
				map[i][k]=1;
			}
		}
		int ans=0;
		for(int i=1;i<=p;i++){
			memset(vis,0,sizeof(vis));
			if(dfs(i)) ans++;
		}
		if(ans==p) puts("YES");
		else puts("NO");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值