PAT(甲级)1053

1053. Path of Equal Weight (30)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

#include <iostream>
#include <set>
#include <vector>

using namespace std;

struct Node{
	friend bool operator < (const Node &n1,const Node &n2);	
	int num;
	int weight;
}Tree[101];



bool operator<(const Node &n1,const Node &n2){
	if(n1.weight > n2.weight)
	    return true;
	else
	    return n1.num < n2.num;
}

set<Node> tlist[101];
vector <int> v;
//watch out that this function is defined using parameters passed by value except vector !!!
void travel(int start,int cur_weight,int sweight,vector <int > &v1){ 
	cur_weight += Tree[start].weight;
	v1.push_back(Tree[start].weight);
	if(cur_weight > sweight)
	    return ;
	if(tlist[start].empty()){
		if(cur_weight == sweight){
			int size = v1.size();
			printf("%d",v1[0]);
			for(int i=1;i<size;i++)
			    printf(" %d",v1[i]);
			printf("\n");
		}
		return ;
	}else{
		int size = tlist[start].size();
		set<Node>::iterator iter = tlist[start].begin();
		while(iter != tlist[start].end()){
//			int weight = iter->weight;      
			int id = iter->num;
			travel(id,cur_weight,sweight,v1);
//			cur_weight -= weight;         //the scope of cur_weight is different from the one above;
			v1.pop_back();                //but when cur_weight is global variable, we need modify its value
			iter++;
		}
	}
}

void display(int n){
	for(int i=0;i<n;i++){
		printf("%d ",Tree[i].weight);
	}
	cout <<endl;
	for(int j=0;j<n;j++){
		if(tlist[j].empty())
		    continue;
		int size = tlist[j].size();
		printf("%02d ",j);
		set<Node>::iterator iter = tlist[j].begin();
		while(iter != tlist[j].end()){
			printf("%02d ",iter->num);
			iter++;
		}
		cout <<endl;
	}
	cout <<endl;
}

int main()
{
	int N,M,S;
//	freopen("test.txt","r",stdin);
	scanf("%d%d%d",&N,&M,&S);
	for(int i=0;i<N;i++){
		scanf("%d",&Tree[i].weight);
		Tree[i].num =i;
	}
	    
	for(int j=0;j<M;j++){
		int ID,num;
		scanf("%d%d",&ID,&num);
		for(int i=0;i<num;i++){
			int tmpid;
			scanf("%02d",&tmpid);
			tlist[ID].insert(Tree[tmpid]);
		}	    
	}
//	display(N);
	travel(0,0,S,v);
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值