PAT 甲级 A1053 Path of Equal Weight(树的遍历)

Given a non-empty tree with root R, and with weight Wi​ assigned to each tree node Ti​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi​ (<1000) corresponds to the tree node Ti​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1​,A2​,⋯,An​} is said to be greater than sequence {B1​,B2​,⋯,Bm​} if there exists 1≤k<min{n,m} such that Ai​=Bi​ for i=1,⋯,k, and Ak+1​>Bk+1​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意:给出所有结点的权重和一个定值s,和各个有子结点的结点的子节点编号,求该树路径权值和等于给定定值s的各个结点的权值。

样例分析:

有20个结点,9个非叶子结点,要等于的路径和为24

给出20个结点的权值

结点的编号id 有k个结点 结点id下的孩子的编号

思路:方法一,给每一个结点的子节点从大到小排序,然后进行DFS遍历,遍历边界是sum==s,且 遍历到的该结点是叶子结点,将这样的路径放入path数组,遍历完这条路径就输出,直到将所有路径都遍历完。

        方法二,DFS遍历所有路径,满足的路径放入ans里面,最后在sort函数里面,用greater比较函数实现按字典顺序从小到大排序,排序完后输出ans里面所有路径。

最后一个测试点过不了,原因是1053 Path of Equal Weight (30 分)(通过最后一个测试点)_永夜等天明的博客-CSDN博客

方法一代码:

	 #include<iostream>
	#include<vector>
	#include<algorithm>
	using namespace std;
	const int maxn=110;
	int n,m,k,child,s,id;
	int path[maxn];
	
	struct node{
		int weight;
		vector<int > child;//存放子结点的地址; 
	}Node[maxn];
	
	bool cmp(int a,int b){//是给整型数组排列,不是结构体数组,不要写出Node a,Node b; 
		return Node[a].weight>Node[b].weight;
	}
	void DFS(int index,int nodenum,int sum){
		if(sum>s)return ;//递归边界;
		if(sum==s){
			if(Node[index].child.size()!=0)return ;//不是叶子结点,有子节点的,sum==s也是不满足题意的;
			for(int i=0;i<nodenum;i++){
				printf("%d",Node[path[i]].weight);//path记录的是该路径的结点的地址(下标),而不是该结点的权重; 
				i==nodenum-1?printf("\n"):printf(" ");
			} 
		}
		for(int i=0;i<Node[index].child.size();i++){//遍历该结点下的子节点;
			int child=Node[index].child[i]; 
			path[nodenum]=Node[index].child[i];//用nodenum作下标,如果路径不合法返回上一层的时候就可以覆盖事先放入path的不合法结点; 
			DFS(child,nodenum+1,sum+Node[child].weight);//递归式,递归该结点下的子节点; 
		}
	}
	int main( ){
		scanf("%d%d%d",&n,&m,&s);
		for(int i=0;i<n;i++)scanf("%d",&Node[i].weight);//依次输入结点的权重; 
		for(int i=0;i<m;i++){//m个结点是有子结点的; 
			scanf("%d %d",&id,&k);//该结点的编号,其子结点的个数;
			for(int j=0;j<k;j++){
				scanf("%d",&child);
				Node[id].child.push_back(child);
			}
			//子结点排序; 
			sort(Node[id].child.begin(),Node[id].child.end( ),cmp);//因为要按递增的顺序输出,那就权重大的先遍历先放入path,就可以实现该效果; 
		}
		path[0]=0;//0号结点是根节点,从根节点出发,先初始化path[0]=0; 
		DFS(0,1,Node[0].weight);//从第一个结点开始,因此nodenum的初始值是1,初始sum应该是第一个结点的权重而不是0; 
		return 0;
	} 


方法二ac代码:
 

	 #include<iostream>
	#include<vector>
	#include<algorithm>
	using namespace std;
	const int maxn=110;
	int n,m,k,child,s,id;
	vector<int> path;//存放满足题意的路径结点; 
	vector<vector<int>> ans;//二维数组,存放所有满足条件的路径的各个结点的权重; 
	struct node{
		int weight;
		vector<int > child;//存放子结点的地址; 
	}Node[maxn];
	

	void DFS(int index,int nodenum,int sum){
		if(sum>s)return ;//修枝;
		if(sum==s){//递归边界;
			if(Node[index].child.size()!=0)return ;//不是叶子结点,有子节点的,sum==s也是不满足题意的;
			ans.push_back(path);//将该条路径放入ans里面;
			return ; 
		}
		for(int i=0;i<Node[index].child.size();i++){//遍历该结点下的子节点;
			int child=Node[index].child[i]; 
			path.push_back(Node[child].weight); 
			DFS(child,nodenum+1,sum+Node[child].weight);//递归式,递归该结点下的子节点;
			path.pop_back( );//vector用的是pop_back清除队尾元素,为进入下一个子节点作准备; 
		}
	}
	int main( ){
		scanf("%d%d%d",&n,&m,&s);
		for(int i=0;i<n;i++)scanf("%d",&Node[i].weight);//依次输入结点的权重; 
		for(int i=0;i<m;i++){//m个结点是有子结点的; 
			scanf("%d %d",&id,&k);//该结点的编号,其子结点的个数;
			for(int j=0;j<k;j++){
				scanf("%d",&child);
				Node[id].child.push_back(child);
			}
		}	
		path.push_back(Node[0].weight);//题目给出编号为0的结点是根节点;
		DFS(0,1,Node[0].weight);//路径已放入根结点,因此起始的路径和应该是根结点的权值
		sort(ans.begin(),ans.end(),greater<vector<int>>( ));//按字典顺序递减排序; 
		for(int i=0;i<ans.size();i++){
			for(int j=0;j<ans[i].size();j++){
				printf("%d",ans[i][j]);
				j==ans[i].size()-1?printf("\n"):printf(" ");
			}
		} 
		return 0;
	} 

改用了用greater函数,按字典顺序从大到小排序,避免同层结点权值相同而不排序的情况。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值