PAT(甲级)1085

1085. Perfect Sequence (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

#include <cstdio>
#define SIZE 100005


//TO speed up, we can use libarary function sort(a,a+n), which exists in <algorithm>
//
//
//
//
//

int a[SIZE];

void swap(int &a,int&b){
	int tmp=a;
	a=b;
	b=tmp;
}

int partion(int a[],int low,int high){
	int key= (low+high)/2;
	swap(a[key],a[high]);
	int i,j;
	i=low;
	j=high-1;
	while(1){
		while(i<high &&a[i]<=a[high])
		    i++;
		while(j>=low &&a[j] > a[high])
		    j--;
		if(i>=j)
		    break;
		else
		    swap(a[i],a[j]);
	}
	swap(a[i],a[high]);
	return i;
}

void myqsort(int a[],int low,int high){
	if(low < high){
		int key=partion(a,low,high);
		myqsort(a,low,key-1);
		myqsort(a,key+1,high);
	}
}
int main()
{
	int N,i,j;
	int p;
	int count=0;
	scanf("%d%d",&N,&p);
	for(i=0;i<N;i++)
	    scanf("%d",&a[i]);
	myqsort(a,0,N-1);
	for(i=0;i<=N-count;i++){
		for(j=i+count;j<N;j++){
			if(a[j] <= a[i]*(long long)p) //in case the result will overflow,we must first convert the data type
			    continue;                //(long long)(a[i]*p) is invalid PLEASE TAKE CARE!!!!!!
			else
			    break;
		}
		if(j-i>count)
		    count=j-i;
	}
	printf("%d\n",count);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值