PAT甲级 A1102

PAT甲级 A1102

题目详情

1102 Invert a Binary Tree (25分)
The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解题思路

首先是根节点,未出现在任何左右节点中的情况即为根节点。对于invert的形式,只需要在处理中将先左后右更改为先右后左即可
以下为AC代码

#include <cstdio>
#include<algorithm>
#include<iostream>
#include<vector>
#include<cmath>
#include<iomanip>
#include<map>
#include<queue>
#include<string>
using namespace std;
class Node {
public:
	int left;
	int right;
	int nos;
};
Node tree[30];
int visited[30];
int N;
void levelorder(int a) {
	queue<int> qus;
	qus.push(a);
	while (!qus.empty()) {
		queue<int> temp;
		while (!qus.empty()) {
			int nos = qus.front();
			qus.pop();
			if (nos == a) {
				cout << a;
			}
			else {
				cout << " " << nos;
			}
			if (tree[nos].right != -1) {
				temp.push(tree[nos].right);
			}
			if (tree[nos].left != -1) {
				temp.push(tree[nos].left);
			}
		}
		qus = temp;
	}
	cout << '\n';
}
int judge = 0;
void inorder(int a) {
	if (a == -1) {
		return;
	}
	inorder(tree[a].right);
	if (judge == 0) {
		cout << a;
		judge = 1;
	}
	else {
		cout << " " << a;
	}
	inorder(tree[a].left);
}
int main() {
	cin >> N;
	for (int i = 0; i < N; i++) {
		char a, b;
		cin >> a >> b;
		if (a == '-') {
			tree[i].left = -1;
		}
		else {
			tree[i].left = a - '0';
			visited[a - '0'] = 1;
		}
		if (b == '-') {
			tree[i].right = -1;
		}
		else {
			tree[i].right = b - '0';
			visited[b - '0'] = 1;
		}
	}
	int beginpos;
	for (int i = 0; i < N; i++) {
		if (visited[i] == 0) {
			beginpos = i;
			break;
		}
	}
	levelorder(beginpos);
	inorder(beginpos);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值