Py||factorial 0s number

题目描述
Given a non-negative integer N, the factorial of N is N!, now you should calculate the number of 0 at the end of N!.

For example, N=10, N! =3628800, then the number of 0 at the end of N! is 2.
输入
Input includes multiple rows of data, one non-negative integer N per line, 0<=N<=100000
输出
For each N input, output the number of 0 at the end of N!., wrap between multiple outputs.
样例输入 Copy
0
1
2
3
4
5
6
7
8
9
10
样例输出 Copy
0
0
0
0
0
1
1
1
1
1
2

def count(n):
    ret=0
    while(n):
        ret+=n//5
        n//=5
    return ret
while True:
    n=int(input())
    print(count(n))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值