数据结构实验之查找二:平衡二叉树

数据结构实验之查找二:平衡二叉树

Time Limit: 400MS  Memory Limit: 65536KB
Problem Description

根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。

Input

输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。

Output

输出平衡二叉树的树根。

Example Input
5
88 70 61 96 120
Example Output
70
Hint
 
Author
xam 
#include<iostream>
#include<bits/stdc++.h>
using namespace std;
struct tree
{
    int data,num;
    tree * lchild,*rchild;
};
int max(int x,int y)
{
    return x>y?x:y;
}
int Deep(tree * root)
{
    if(!root)
        return -1;
    else
        return root->num;
}
tree * LL(tree * root)
{
    tree * q=root->lchild;
    root->lchild=q->rchild;
    q->rchild=root;
    q->num=max(Deep(q->lchild),Deep(q->rchild))+1;
    root->num=max(Deep(root->lchild),Deep(root->rchild))+1;
    return q;
}
tree * RR(tree * root)
{
    tree * q=root->rchild;
    root->rchild=q->lchild;
    q->lchild=root;
    q->num=max(Deep(q->lchild),Deep(q->rchild))+1;
    root->num=max(Deep(root->lchild),Deep(root->rchild))+1;
    return q;
}
tree * RL(tree * root)
{
    root->rchild=LL(root->rchild);
    return RR(root);
}
tree * LR(tree * root)
{
    root->lchild=RR(root->lchild);
    return LL(root);
}
tree * creat(tree * root,int x)
{
    if(!root)
    {
        root=new tree;
        root->lchild=root->rchild=NULL;
        root->data=x;
        root->num=0;
    }
    else if(x<root->data)
    {
        root->lchild=creat(root->lchild,x);
        if(Deep(root->lchild)-Deep(root->rchild)>1)
        {
            if(x< root->lchild->data)
                root=LL(root);
            else
                root=LR(root);
        }
    }
    else if(x> root->data)
    {
        root->rchild=creat(root->rchild,x);
        if(Deep(root->rchild)-Deep(root->lchild)>1)
        {
            if(x> root->rchild->data)
                root=RR(root);
            else
                root=RL(root);
        }
    }
    root->num=max(Deep(root->lchild),Deep(root->rchild))+1;
    return root;
}
int main()
{
    int n,x,i,m;
    cin>>n;
        tree * root=NULL;
        //root=NULL;
        for(i=0;i<n;i++)
        {
            cin>>m;
            root=creat(root,m);
        }
        cout<<root->data<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值