uva11806 Cheerleaders

Inmost professional sporting events, cheerleaders play a major role inentertaining the spectators. Their roles are substantial during breaks andprior to start of play. The world cup soccer is no exception. Usually thecheerleaders form a group and perform at the centre of the field. In additionto this group, some of them are placed outside the side line so they are closerto the spectators. The organizers would like to ensure that at least onecheerleader is located on each of the four sides. For this problem, we willmodel the playing ground as an M*Nrectangular grid. The constraints for placing cheerleaders are described below:

 

§  There should be at least one cheerleader oneach of the four sides. Note that, placing a cheerleader on a corner cell wouldcover two sides simultaneously.

§  There can be at most one cheerleader in acell.

§  All the cheerleaders available must beassigned to a cell. That is, none of them can be left out.

 

 

Theorganizers would like to know, how many ways they can place the cheerleaderswhile maintaining the above constraints. Two placements are different, if thereis at least one cell which contains a cheerleader in one of the placement butnot in the other. 

 

 

 

Input

 

Thefirst line of input contains a positive integer T<=50, which denotes the number of test cases.T lines then follow each describing onetest case. Each case consists of three nonnegative integers,2<=M, N<=20 and K<=500. Here M is the number of rows andNis the number of columns in the grid. Kdenotes the number of cheerleaders that must be assigned to the cells in thegrid.

 

 

Output

 

For each case of input, there will be one line ofoutput. It will first contain the case number followed by the number of ways toplace the cheerleaders as described earlier. Look at the sample output forexact formatting. Note that, the numbers can be arbitrarily large. Thereforeyou must output the answers modulo 1000007.

 

Sample Input

Sample Output

2

2 2 1

2 3 2

Case 1: 0

Case 2: 2


解析

数学,用容斥原理。(参阅大白书2.1基本计数方法)每一项前面的正负号——奇数个集合为正,偶数个集合为负。

组合数可以先预处理:

	Comb[0][0]=1;
	for(int i=1;i<=MAXK;i++)
	{
		Comb[i][0]=Comb[i][i]=1;
		for(int j=1;j<i;j++) Comb[i][j]=(Comb[i-1][j-1]+Comb[i-1][j])%MOD;
	}
代码
#include<cstdio>

using namespace std;

#define LOCAL
const int MOD=1000007,MAXK=500;
int Comb[MAXK+10][MAXK+10];

void prework()
{
	Comb[0][0]=1;
	for(int i=1;i<=MAXK;i++)
	{
		Comb[i][0]=Comb[i][i]=1;
		for(int j=1;j<i;j++) Comb[i][j]=(Comb[i-1][j-1]+Comb[i-1][j])%MOD;
	}
#ifdef LOCAL
	for(int i=1;i<=10;i++)
		for(int j=0;j<=i;j++)
			printf("%d%c",Comb[i][j],j!=i ? ' ' : '\n');
#endif
}

void work()
{
	int N,M,K,sum=0; scanf("%d%d%d",&N,&M,&K);

	for(int i=0;i< 1<<4;i++)
	{
		int b=0,r=N,c=M;
		if(i&1) r--,b++;
		if(i&2) r--,b++;
		if(i&4) c--,b++;
		if(i&8) c--,b++;

		if(b&1) sum-=Comb[r*c][K];//奇数个集合为正
		else sum+=Comb[r*c][K];//偶数个集合为负
		sum=sum%MOD;
/*
		if(b&1) sum = (sum+MOD-Comb[r*c][K])%MOD;
        else sum = (sum+Comb[r*c][K])%MOD;
*/		
	}
	printf("%d",(sum+MOD)%MOD);
}

int main()
{
#ifdef LOCAL
	freopen("uva11806.in","r",stdin);
#endif

	prework();

	int T; scanf("%d",&T);
	for(int i=1;i<=T;i++)
	{
		printf("Case %d: ",i);
		work();
		printf("\n");
	}
#ifdef LOCAL
	while(1);
#endif
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值