UVA 11806 Cheerleaders

Question:
In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their
roles are substantial during breaks and prior to start of play. The world cup soccer is no exception.
Usually the cheerleaders form a group and perform at the centre of the field. In addition to this group,
some of them are placed outside the side line so they are closer to the spectators. The organizers would
like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we
will model the playing ground as an M × N rectangular grid. The constraints for placing cheerleaders
are described below:
• There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader
on a corner cell would cover two sides simultaneously.
• There can be at most one cheerleader in a cell.
• All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.
The organizers would like to know, how many ways they can place the cheerleaders while maintaining
the above constraints. Two placements are different, if there is at least one cell which contains a
cheerleader in one of the placement but not in the other.
Input
The first line of input contains a positive integer T ≤ 50, which denotes the number of test cases. T
lines then follow each describing one test case. Each case consists of three nonnegative integers, 2 ≤ M,
N ≤ 20 and K ≤ 500. Here M is the number of rows and N is the number of columns in the grid. K
denotes the number of cheerleaders that must be assigned to the cells in the grid.
Output
For each case of input, there will be one line of output. It will first contain the case number followed by
the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact
formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers
modulo 1000007.
Sample Input
2
2 2 1
2 3 2
Sample Output
Case 1: 0
Case 2: 2
题意大意:一个方阵要四个边界都要有人站(即最上边最下边最左边最右边)
思路:利用容斥定理,求A,B,C,D四边没人站
(http://acm.hust.edu.cn/vjudge/contest/121560#problem/C)

#include <iostream>
#include <cstdio>
using namespace std;
const int MOD=1000007;
typedef long long LL;
LL f[405][405];
int main()
{
    for(int i=0;i<=400;i++)
    {
        f[i][i]=f[i][0]=1;
        for(int j=1;j<i;j++)
            f[i][j]=(f[i-1][j-1]+f[i-1][j])%MOD;  //打表,打印杨辉三角
    }
    int T,n,m,k;
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        scanf("%d%d%d",&n,&m,&k);
         LL way=0;
        for(int j=0;j<=15;j++)
        {
            int t=0,l=n,c=m ;
            if(j&1)      //充分利用位运算求p(a)+p(b)+p(c)......-p(abcd)
            {t++;l--;}
            if(j&2)
            {t++;c--;}
            if(j&4)
            {t++;l--;}
            if(j&8)
            {t++;c--;}
            if(t%2==0)  //原本偶数应该被减,但现在是总数减去,所以偶数被加,奇数被减
                way=(way+f[c*l][k])%MOD; 
            else way=(way+MOD-f[c*l][k])%MOD; //减法求MOD
        }
        printf("Case %d: %lld\n",i,way);
    }
    return 0;
}

体会:遇见复杂问题不易直接求解的可以换个思路,利用容斥定理,同时要灵活运用位运算。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值