LA 4888 Railroad

Description

Download as PDF

A train yard is a complex series of railroad tracks for storing, sorting, or loading/unloading railroad cars. In this problem, the railroad tracks are much simpler, and we are only interested in combining two trains into one.

merging tracks

Figure 1: Merging railroad tracks.

The two trains each contain some railroad cars. Each railroad car contains a single type of products identified by a positive integer up to 1,000,000. The two trains come in from the right on separate tracks, as in the diagram above. To combine the two trains, we may choose to take the railroad car at the front of either train and attach it to the back of the train being formed on the left. Of course, if we have already moved all the railroad cars from one train, then all remaining cars from the other train will be moved to the left one at a time. All railroad cars must be moved to the left eventually. Depending on which train on the right is selected at each step, we will obtain different arrangements for the departing train on the left. For example, we may obtain the order 1,1,1,2,2,2 by always choosing the top train until all of its cars have been moved. We may also obtain the order 2,1,2,1,2,1 by alternately choosing railroad cars from the two trains.

To facilitate further processing at the other train yards later on in the trip (and also at the destination), the supervisor at the train yard has been given an ordering of the products desired for the departing train. In this problem, you must decide whether it is possible to obtain the desired ordering, given the orders of the products for the two trains arriving at the train yard.

Input

The input consists of a number of cases. The first line contains two positive integers N1 N2 which are the number of railroad cars in each train. There are at least 1 and at most 1000 railroad cars in each train. The second line contains N1 positive integers (up to 1,000,000) identifying the products on the first train from front of the train to the back of the train. The third line contains N2 positive integers identifying the products on the second train (same format as above). Finally, the fourth line contains N1+N2 positive integers giving the desired order for the departing train (same format as above).

The end of input is indicated by N1 = N2 = 0.

Output

For each case, print on a line possible if it is possible to produce the desired order, or not possible if not.

Sample input

3 3
1 2 1
2 1 1
1 2 1 1 2 1
3 3
1 2 1
2 1 2
1 1 1 2 2 2
0 0

Sample Output

possible
not possible

解析

动态规划,记忆化搜索。开始居然没看出来。。。

开始超时,因为dp数组开的太大了,导致速度减慢。

dp[i][j]表示第一个火车用前i节,第二个火车用前j节,是否能组成目标顺序的前i+j节。可以为1,不可以为-1,未知为0。

#include<cstdio>
#include<stack>
#include<queue>
#include<cstring>

using namespace std;

#define LOCAL

int n1,n2;
int t3[2100],t1[2100],t2[2100];
int dp[1010][1010];
bool find(int x,int y)
{
	if(dp[x][y]>0) return 1;
	if(dp[x][y]<0) return 0;

	if(t1[x]==t3[x+y] && find(x-1,y)) {dp[x][y]=1; return 1;}
	if(t2[y]==t3[x+y] && find(x,y-1)) {dp[x][y]=1; return 1;}
	dp[x][y]=-1; return 0;
}
bool work()
{	
	bool flag=0;

	for(int i=1;i<=n1+n2;i++) scanf("%d",&t3[i]);
	memset(dp,0,sizeof(dp)); dp[0][0]=1;

	if(find(n1,n2)) return 1;
	else return 0;
}

int main()
{
	while(scanf("%d%d",&n1,&n2)==2)
	{
		if(n1==0 && n2==0) break;
		for(int i=1;i<=n1;i++) scanf("%d",&t1[i]);
		for(int i=1;i<=n2;i++) scanf("%d",&t2[i]);

		if(work()) printf("possible\n");
		else printf("not possible\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值