POJ-3007 Organize Your Train part II (字符串hash)

Description

RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


Figure 1: Layout of the exchange lines

A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

  [3:1]
    abc+d  cba+d  d+abc  d+cba
  [2:2]
    ab+cd  ab+dc  ba+cd  ba+dc  cd+ab  cd+ba  dc+ab  dc+ba
  [1:3]
    a+bcd  a+dcb  bcd+a  dcb+a

Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

Input

The entire input looks like the following.

the number of datasets = m
1st dataset
2nd dataset

...
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

Output

For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

Sample Input

4
aa
abba
abcd
abcde

Sample Output

1
6
12
18

Source


题意:将一个字符串可以任意分成两节,任意颠倒顺序,问最终会得到几个字符串。


分析:字符串hash,我没有进行查找判重操作,直接开了一个unsigned ll的set去记录出现过的值。


#include <set> 
#include <queue>
#include <vector>
#include <cstdio>
#include <utility>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
char S[100005];
unsigned long long xl[100005],Hash[100005],Rhash[100005];
int T;
int main()
{
	xl[0] = 1;
	for(int i = 1;i <= 100000;i++) xl[i] = xl[i-1]*27;
	scanf("%d",&T);
	while(T--)
	{
		int ans = 1;
		set <unsigned long long> f;
		scanf("%s",S);
		int n = strlen(S);
		Hash[n] = 0;
		Rhash[0] = S[0];
		for(int i = n-1;i >= 0;i--) Hash[i] = S[i] + Hash[i+1]*27;
		for(int i = 1;i < n;i++) Rhash[i] = S[i] + Rhash[i-1]*27;
		f.insert(Hash[0]);
		for(int i = 0;i < n-1;i++)
		{	
			if(!f.count(Rhash[i]+Hash[i+1]*xl[i+1]))
			{
				f.insert(Rhash[i]+Hash[i+1]*xl[i+1]); 
				ans++;
			} 
			if(!f.count(Rhash[i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])*xl[i+1]))
			{
				f.insert(Rhash[i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])*xl[i+1]); 
				ans++;
			}
			if(!f.count(Hash[0]-Hash[i+1]*xl[i+1]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])*xl[i+1]))
			{
				f.insert(Hash[0]-Hash[i+1]*xl[i+1]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])*xl[i+1]); 
				ans++;
			}
			if(!f.count(Rhash[i]*xl[n-1-i]+Hash[i+1]))
			{
				f.insert(Rhash[i]*xl[n-1-i]+Hash[i+1]); 
				ans++;
			} 
			if(!f.count(Rhash[i]*xl[n-1-i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])))
			{
				f.insert(Rhash[i]*xl[n-1-i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])); 
				ans++;
			}
			if(!f.count((Hash[0]-Hash[i+1]*xl[i+1])*xl[n-1-i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])))
			{
				f.insert((Hash[0]-Hash[i+1]*xl[i+1])*xl[n-1-i]+(Rhash[n-1]-Rhash[i]*xl[n-1-i])); 
				ans++;
			}
			if(!f.count((Hash[0]-Hash[i+1]*xl[i+1])*xl[n-1-i]+Hash[i+1]))
			{
				f.insert((Hash[0]-Hash[i+1]*xl[i+1])*xl[n-1-i]+Hash[i+1]); 
				ans++;
			}
		}
		if(n > 1) cout<<ans<<endl;
		else cout<<0<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值