ZOJ 3623 Battle Ships

Description

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

解析

动态规划+优先队列

最开始写了个O(N^2)的算法,显然会T

#include<cstdio>
#include<cstring>
using namespace std;

typedef long long LL;
int N,V[50010],S[50010];
LL dp[50010];//表示第i天吃到西瓜的最小代价

inline LL min(LL a,LL b)
{return a<b?a:b;}
inline void updata(LL &a,LL b)
{a=min(a,b);}
int main()
{
	while(scanf("%d",&N)==1)
	{
	    for(int i=1;i<=N;i++) scanf("%d",&V[i]);
	    for(int i=1;i<=N;i++) scanf("%d",&S[i]);
		memset(dp,0x3f,sizeof(dp));
		dp[0]=0;
	    for(int i=1;i<=N;i++)
                for(int j=1;j<=i;j++)
                    if(j+S[j]>i) updata(dp[i],dp[j-1]+V[j]);
	
	    printf("%lld\n",dp[N]);
	}
	return 0;
}
为什么j+S[j]>i时转移的是dp[j-1]+V[j]而不是dp[j]+V[j]呢?因为我们在第j天决定买新西瓜时,当天的西瓜要被丢掉的。所以只要能在j-1天吃到西瓜就好了。

所以我们只要在[1,i]天以内找到最小的dp[k-1]+V[k](当然这个k必须满足k+S[k]>i)

所以我用了优先队列,排序关键字是dp[k-1]+V[k]的小根堆。每次遇到k+S[k]<=i的就弹出(因为k+S[k]是一定的,i不断增大。后面的i更大,更不可能满足k+S[k]>i了)

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;

typedef long long LL;
int N,V[50010],S[50010];
LL dp[50010];//表示第i天吃到西瓜的最小代价

struct cmp
{
	bool operator()(int a,int b)
	{return dp[a-1]+V[a]>dp[b-1]+V[b];}
};
priority_queue<int,vector<int>,cmp> q;

int main()
{
	while(scanf("%d",&N)==1)
	{
	    for(int i=1;i<=N;i++) scanf("%d",&V[i]);
	    for(int i=1;i<=N;i++) scanf("%d",&S[i]);
		memset(dp,0x3f,sizeof(dp)); dp[0]=0;

		while(q.size())q.pop(); q.push(0);
	    for(int i=1;i<=N;i++)
		{
			int u;
			while(1)
			{
				u=q.top();
				if(u+S[u]>i) break;
				q.pop();
				if(q.empty()) {u=i;break;}
			}
			dp[i]=dp[u-1]+V[u];
			q.push(i);
		}
		printf("%lld\n",dp[N]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值