1044 火星数字

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

分析:

       显而易见,接收数据时要用string,因为有空格,所以用到了getline()函数。然后要判断接收到的是地球数字还是火星数字,可以发现,那些奇葩的符号都是火星文(一如当年那群中二的少年少女们),它们是以字母开头的。而字母的ASCII值大于数字,可以此为依据进行判断。

       正常数字转换为火星文很easy,先把接收到的string数据转化为int,后面的就不用多说了。

      火星文怎么转化为正常数字呢?首先string的长度不定,它可能是两个单词,也可能是一个单词。首先用temp取得它的第一个单词,遍历一遍判断是不是高位数字。如果是,则更改result的值,并删除掉原字符串的第一个单词;如果不是则继续。到现在,如果有剩下的单词,只能是低位数字了。遍历一遍修改result值即可。

#include<iostream>
#include<sstream>

using namespace std;

string high[12] = {"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string low[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};

void EToM(string num){ //Earth number to Mars number
	//String to int
	int Enum;
	ostringstream os;
	os << num;
	istringstream is(os.str());
	is >> Enum;
	//Print
	if(Enum / 13 - 1 >= 0){
		cout << high[Enum / 13 - 1];
		if(Enum % 13 != 0) cout << ' ' << low[Enum % 13];	//when input is 13, the output is supposed to be "tam", not "tam tret"
		cout << '\n';
	}
	else cout << low[Enum % 13] << endl;
}

void MToE(string num){ //Mars number to Earth number
	int result = 0;
	string temp;
	temp = num.substr(0, 3);
	for(int i = 0; i < 12; i++){
		if(temp == high[i]){
			result += (i + 1) * 13;
			num.erase(0, 4);
			break;
		}
	}
	if(num.length() > 0){
		temp = num.substr(0, 3);
		for(int i = 0; i < 13; i++){
			if(temp == low[i]){
				result += i;
				break;
			}
		}
	}
	cout << result << endl;
}

int main(){
	string num;
	int N;
	cin >> N;
	getchar();
	for(int i = 0; i < N; i++){
		getline(cin, num);
		if(num[0] > '9') MToE(num);
		else EToM(num);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值