1021 Deepest Root(DFS,连通分量)

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

Analyze:

    We can list the number of connected components to judge whether these nodes can be considered a tree. If the number is greater than 2, we're suppose to print 'Error'. Then we need to use dfs for the second time to record those nodes that are deepest. Actually, we can find some nodes that are deepest at the first time, but we still ignore some nodes. A leaf can be a root.

    For example, 1 - 2 - 3: At the first dfs, you maybe start with node 1, so node 3 will be recorded. In fact, 1 can also be the deepest root. That's why we need secondly dfs.

#include<iostream>
#include<vector>
#include<set>
#include<algorithm>

using namespace std;

int n, max_height;
vector<vector<int>> v;
vector<int> temp;
set<int> s;
bool visited[10001];

void Dfs(int node, int height){
	if(height > max_height){
		temp.clear();
		temp.push_back(node);
		max_height = height;
	}else if(height == max_height){
		temp.push_back(node);
	}
	visited[node] = true;
	for(int i = 0; i < v[node].size(); i++){
		if(visited[v[node][i]] == false)
			Dfs(v[node][i], height + 1);
	}
}

int main(){
	int n1, n2, cnt = 0;
	scanf("%d", &n);
	v.resize(n + 1);
	for(int i = 0; i < n - 1; i++){
		scanf("%d %d", &n1, &n2);
		v[n1].push_back(n2);
		v[n2].push_back(n1);
	}
	for(int i = 1; i <= n; i++){
		if(visited[i] == false){
			Dfs(i, 1);
			if(i == 1){
				if(temp.size() > 0) n1 = temp[0];
				for(int j = 0; j < temp.size(); j++)
					s.insert(temp[j]);
			}
			cnt++;
		}
	}
	if(cnt > 1){
		printf("Error: %d components", cnt);
	}else{
		fill(visited, visited + 10001, false);
		temp.clear();
		Dfs(n1, 1);
		for(int i = 0; i < temp.size(); i++)
			s.insert(temp[i]);
		for(auto it = s.begin(); it != s.end(); it++)
			printf("%d\n", *it);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值