A - Brackets

A - Brackets
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意是给你一串括弧符号,要判断一共可以有多少个配对的,只有(),[],这两种配对方法。

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[110][110];
char s[110];
bool match(char a,char b)
{
    if(b-a==1||b-a==2)
        return true;
    else return false;
}
int main()
{
    while(~scanf("%s",s)&&s[0]!='e')
    {
        int len=strlen(s);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<len;i++)
        {
            if(match(s[i],s[i+1]))
                dp[i][i+1]=2;            //一个肯定是不能配对成功的,所以直接预处理长度为2 的,如果能配对则为2,否则为0
        }
        for(int k=3;k<=len;k++)               //长度为1和2 的都处理过了,直接从长度为3的开始计算
        {
            for(int i=0;i+k-1<len;i++){
            if(match(s[i],s[i+k-1]))
                dp[i][i+k-1]=dp[i+1][i+k-2]+2;                      //如果长度为k的区间两端的括弧能够配对,则等于中间的配对数加上2
            for(int j=i;j<i+k-1;j++)                                    //从i到长度为k的最后一位,一直枚举断点
            {
                dp[i][i+k-1]=max(dp[i][i+k-1],dp[i][j]+dp[j+1][i+k-1]);                      //取某个断点能组成的最大配对数
            }
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值