HDU 6055 组合正多边形问题



Regular polygon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 86


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
      
      
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
      
      
1 2
 

Source
 

题意:输入n个点,要求出这些点能组成多少个正多边形(边长内角全部相等)而且是整数点,那么既然是整数点,那么组成的图形只能是正方形

所以只要枚举两个点,旋转90度去找另外两个点是否存在,最后答案除4就可以了

#include<bits/stdc++.h>
using namespace std;
#define MAXN 800
struct point{
	int x,y;
}p[MAXN];
int ans;
int has[MAXN][MAXN];
point change(point a,point b){
	int x = a.x - b.x;
	int y = a.y - b.y;
	struct point c;
	c.x = b.x - y;
	c.y = b.y + x;
	return c;
}
bool isHas(point a){
	if(has[a.x][a.y])
		return true;
	return false;
} 
bool solve(int i,int j){
	point a = p[i];
	point b = p[j];
	point c = change(a,b);
	point d = change(b,c);
	if(isHas(c) && isHas(d))
		return true;
	return false;
}
int main(){
	int n;
	while(scanf("%d",&n) != EOF){
		memset(has,0,sizeof(has));
		for(int i = 1;i <= n;i++){
			scanf("%d %d",&p[i].x,&p[i].y);
			p[i].x += 300;
			p[i].y += 300;
			has[p[i].x][p[i].y] = 1;
		}
		ans = 0;
		for(int i = 1;i <= n;i++){
			for(int j = 1;j <= n;j++){
				if(i != j && solve(i,j)){
					ans++;
				}
			}
		}
		printf("%d\n",ans / 4);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值