HDU 2647 Reward 拓扑排序

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11085    Accepted Submission(s): 3548


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
 
 
2 1 1 2 2 2 1 2 2 1
 

Sample Output
 
 
1777 -1
 

Author
dandelion
 

题意:有N个人需要发奖金,每个人最少888元,但是有些人会要求他的奖金必须比某个人高

输入 n 和 m 表示有 n个人 m 个要求,m行每行输入两个数 a 和 b 表示 a的奖金必须比b高

老板要尽量满足他们的要求并且花最少的钱

比如一组样例  

    4 3

    2 1

    3 2

    3 4

2 要比 1高, 3 比 2 高,3 比 4 高,拓扑排序思想,a 比 b 高则记录  du[a]++    用动态数组记录比 b 高的人

然后度为 0 的就可以优先发配奖金,给他们最少的钱888,然后把发配了奖金的人的上级(比他高的人) 的度减一

若出现减完度为0的人,表示这个人的要求可以满足了,给他发配奖金,奖金是比他少的人中奖金最多的那个 加 一

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#define mem(a,x) memset(a,x,sizeof(a))
#define ll long long
#define maxn 10005
#define maxm 20005
using namespace std;


priority_queue<int>q;
vector<int>vec[maxn];
int du[maxn],order[maxn];

int topo_sort(int n){
	for(int i = 1;i <= n;i++){
		if(du[i] == 0){
			q.push(i);
		}
	}

	int ans = 0;
	int cnt = 0;
	while(!q.empty()){
		int p = q.top();
		cnt++;
		q.pop();
		int tmp = order[p];
		ans += tmp;
		int sz = vec[p].size();
		for(int i = 0;i < sz;i++){
			int v = vec[p][i];
			du[v]--;
			if(du[v] == 0){
				q.push(v);
			}
			order[v] = max(order[v],tmp + 1);
		}
	}
	if(cnt != n){
		return -1;
	}
	return (ans + 888 * n);
} 

void init(int n){
	for(int i = 0;i <= n;i++){
		vec[i].clear();
		du[i] = 0;
		order[i] = 0;
	}
}

int main(){
	int n,m,u,v;
	while(scanf("%d %d",&n,&m) != EOF){
		init(n);
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&u,&v);
			du[u]++;
			vec[v].push_back(u);
		}
		printf("%d\n",topo_sort(n));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值