HDU 2647 Reward (拓扑排序)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7319    Accepted Submission(s): 2297


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 

Author
dandelion
 

Source
 

Recommend
yifenfei   |   We have carefully selected several similar problems for you:   3342  1811  1142  2729  1548 
思路:数据较大要用邻接表存储,对于相同等级的先用数组储存,
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int head[11000];
int indegree[11000];
int vis[11000];
int num;
struct node
{
	int to,next;
}edge[110000];
void init()
{
	memset(head,-1,sizeof(head));
	num=0;
	memset(indegree,0,sizeof(indegree));
} 
void add(int a,int b)
{
	edge[num].to=b;
	edge[num].next=head[a];
	head[a]=num++;
	indegree[b]++;
}
int top(int n)
{
	int i,j,k,l,c,sum,num,t;
	int temp[11000];
	c=0;sum=0,j=0;
	num=888;
	memset(vis,0,sizeof(vis));
	while(1)
	{
		memset(temp,0,sizeof(temp));
		k=0;
		for(i=1;i<=n;i++)
		{
			if(!vis[i]&&indegree[i]==0)
		    {
			    vis[i]=1;
			    c++;
			    sum+=num;
			    temp[k++]=i;//把前驱数量为0的都放入数组 
			    
		    }
		}
		//printf("num1=%d\n",num);
		//printf("sum=%d\n",sum);
	    if(c>=n)
	    return sum;
	    if(!k)//存在环 
	    return -1;
	    for(i=0;i<k;i++)//遍历所有前驱为0的结点 
	    {
	    	t=temp[i];
	    	for(j=head[t];j!=-1;j=edge[j].next)
	    	{
	    		int tmp=edge[j].to;
	    		indegree[tmp]--;
			}
		}
		num++;
		//printf("num=%d\n",num);
	} 	
}
int main()
{
	int n,m,i,j,a,b;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			add(b,a);//注意!!!! 
		}
		int ans=top(n);
		printf("%d\n",ans);
	}
	return 0;
}


 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值