hdu 2647 Reward 拓扑排序

Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1

Sample Output
  
  
1777 -1

题目大题说的是:BOSS要给员工发钱,但是,有一些员工有要求,他们要比另外

一些员工的奖金高,有一些员工没有要求,即,最低给888就可以.BOSS又不想多花钱,现在,我们需要找一种发奖金方式使

得BOSS给的钱最少.

,如果p的奖金比q少,那么存在一条边p->q,可以由这个关系建立一张图,链式存储法(我试过矩阵存,但是内存超了),而如果p->q,且pq直接相接,则有money(p)+1=money(q),所以,可以用拓扑排序的方式遍历图,就可以找到每个点要付的奖金.
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
#define maxn 10005
int m,n;
int mo[maxn],in[maxn];
queue<int>q;
vector<int> pm[maxn],pv;
void topsort()
{
    int i,j,t,s;
    for(i=1;i<=n;i++)
    {
        if(in[i]==0)
        {
            q.push(i);
            mo[i]=888;
        }
    }
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        for(i=0;i<pm[t].size();i++)
        {
            in[pm[t][i]]--;
            if(in[pm[t][i]]==0)
            {
                q.push(pm[t][i]);
                mo[pm[t][i]]=mo[t]+1;
            }
        }
    }
    for(i=1;i<=n;i++)
    {
        if(in[i])
        {
            cout<<-1<<endl;
            return ;
        }

    }
    s=0;
    for(i=1;i<=n;i++)
    s+=mo[i];
    cout<<s<<endl;
}
int main()
{
    int i,s,e;
    while(cin>>n>>m)
    {
        memset(in,0,sizeof in);
        memset(mo,0,sizeof mo);
        for(i=1;i<=n;i++)
        pm[i].clear();
        while(m--)
        {
            cin>>s>>e;
            pm[e].push_back(s);
            in[s]++;
        }
        topsort();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值