poj 2533 Longest Ordered Subsequence 深夜再来一波DP

154 篇文章 1 订阅
26 篇文章 0 订阅
本文介绍了如何利用动态规划(DP)解决POJ 2533问题,详细解析了输入、输出格式,并给出了样例输入和输出,深入探讨ACM竞赛中的数据结构应用。
摘要由CSDN通过智能技术生成
Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 35745 Accepted: 15685

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
 
第一次做这样的题,推出公式后就A了,跟hdu 1087差不多,一个事实求最大上升子序列,一个是求最长上升子序列。
	状态转移公式:dp[i] = max(dp[j]+1,dp[i])(Ai>Aj&&j<i);i表示以Ai结尾的最长上升子序列。
没啥好说的,直接代码:
 
#include <stdio.h>
#define INF 100000000
#define MAX 1010

int max(int a, int b)
{
	return a>b?a:b ;
}
int main()
{
	int n , dp[MAX] , num[MAX];
	while(~scanf("%d",&n))
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&num[i]);
			dp[i] = 0 ;
		}
		dp[0] = 0 ;
		int ans = -INF ;
		for(int i = 1 ; i <= n ; ++i)
		{
			dp[i] = 1 ;
			for(int j = 1 ; j <= i ; ++j)
			{
				if(num[i]>num[j])
					dp[i] = max(dp[j]+1,dp[i]);
			}
			ans = max(dp[i],ans) ;
		}
		printf("%d\n",ans) ;
	}
	return 0 ;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值