2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛 The Best Seat in ACM Contest 看清题目后,我是真哭了。。。。。


The Best Seat in ACM Contest
Time Limit: 1000MS Memory limit: 65536K

题目描述

Cainiao is a university student who loves ACM contest very much. It is a festival for him once when he attends ACM Asia Regional Contest because he always can find some famous ACMers there.
Cainiao attended Asia Regional Contest Fuzhou Site on November 20, 2011. After he got seat map
, he wanted to know which seat is the best one.
Cainiao have joined so many QQ Group about ACM/ICPC that he is almost familiar with the strength of each team. In his mind, the value of a seat is defined as following:

1. Strength of each team can be expressed as a positive integer.
2. The value of a seat is related to the adjacent seat (up/down/left/right, only four directions being considering).
3. For an adjacent seat, if the strength of this team is stronger than yours, the absolute value of difference of two teams should be added to your seat, otherwise, the absolute value of difference should be subtracted from your seat.
4. If the adjacent seat is empty (which means you are located at the most left/right/up/down), the value of your seat should be subtracted 1.
5. The best one in a contest is the seat that has the highest value.
6. The initial value of the seat is ZERO.

For example, there are 12 ( 3 X 4 ) teams in a contest, the strength of each team is as figure (a), and then you can calculate the value of each seat as figure (b).

 

输入

Input contain a positive integer T( T <=50 ) in the first line, which means T cases.
The first line of each case contains two positive integers N and M (3 <= N, M <= 20) which means the row and column number of the teams, then N rows following, each line contains M positive integers that represent the strengths of the teams.

输出

For each case, first output the case number, and then output the value and row number and column number of the best seat in one line for each case. 
If there are multiple solutions for one case, you should output the seat whose row number is largest and only output the seat whose column number is largest if still overlapping.

示例输入

1
3 4
1 5 3 4
6 3 3 4
4 3 2 1

示例输出

Case 1: 7 1 1

提示

 

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛


第一眼看到这个题目就觉得简单,然后没看完题目大概了解意思后开写,然后为了考虑N==1和M==1的情况,我是
纠结了差不多一个小时啊,换了几种思路,每次都是边界情况搞不定,最后终于行了吧。。。仔细一看题目,我去啊。。。(20=>N,M>=3)
当时就有一种想死的赶脚。。。。我怎么就这么傻B呢。。。

幸好最后想出了一种简单实现行与列优先搜索的办法,还算有点收获。。。。
#include <iostream>
#include <cstring>
using namespace std;

int seats[25][25];
int nvalue[25][25];
int N,M,t,sum,i,j,nmax,ni,nj,ncase;

void cal()
{
    int i,j;

    for(i = 1; i <= N; i++)
        for(j = 1; j <= M; j++)
        {
            nvalue[i][j] += seats[i][j+1] + seats[i][j-1] + seats[i+1][j] + seats[i-1][j] - 4*seats[i][j];
        }
    for(i = 1; i <= N; i++)
    {
        nvalue[i][M] +=seats[i][M];
        nvalue[i][1] +=seats[i][1];
    }
    for(j = 1; j <= M; j++)
    {
        nvalue[1][j] += seats[1][j];
        nvalue[N][j] += seats[N][j];
    }
}


int main()
{
    cin >> t;
    ncase = 1;
    while(t--)
    {
        cin >> N >> M;
        for(i = 0;i < 25;i++)
        for(j = 0;j < 25;j++)
        seats[i][j] = -1;
        memset(nvalue,0,sizeof(nvalue));
        for(i = 1;i <= N;i++)
            for(j = 1;j <= M;j++)
        {
            cin >> seats[i][j];
        }
        cal();
        nmax = nvalue[N][M];
        ni =N;
        nj =M;
        for(i = N;i >=1 ;i--)//倒着搜,为了实现行最大
            for(j = M;j >=1;j--)//同上,实现列最大
            {
                if(nmax < nvalue[i][j])//不能用等于号,不然实现不了按行与列排序的顺序
            {
                nmax = nvalue[i][j];
                ni = i;nj = j;
            }
            }
         cout << "Case "<< ncase++ << ": "<<nmax<<" "<<ni<<" "<<nj<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值